Support » Plugin: PayPal for WooCommerce » Sucuri warning for this plugin after latest version release

  • Resolved thewpguy

    (@thewpguy)


    Sucuri has flagged the following file as a security warning.

    wp-content/plugins/paypal-for-woocommerce/classes/wc-gateway-paypal-pro-angelleye.php

    Definition: php.phishing.visa.001.03

    Can you please let us all know if its just a coding issue and the plugin hasn’t been compromised in the latest update which is when this warning started.

Viewing 4 replies - 1 through 4 (of 4 total)
  • We got the same warning from Sucuri right after updating this plugin today.

    • This reply was modified 4 years, 4 months ago by blueocean109.
    Plugin Contributor angelleye

    (@angelleye)

    We’ve had a few reports of this lately, and in each case Securi wound up telling the user it was a false flag. I’m not exactly sure why they just suddenly started hitting that file because not much has changed in that file for a while now.

    I am trying to get some info from them about how to stop this from happening, but for now I can assure you that the plugin has not been compromised.

    Plugin Contributor angelleye

    (@angelleye)

    Sucuri said it was commented code that was causing the false flag. I have just released an update that removes this unused code, so the Sucuri service should not flag that any more.

    Thread Starter thewpguy

    (@thewpguy)

    Thank you very much for sorting that out. I can confirm that the sucuri Server side scanner is now happy with the code again after the update.

    Greatly appreciate you work on this.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Sucuri warning for this plugin after latest version release’ is closed to new replies.