• I have set the Timezone of a WordPress 5.0.3 site to UTC+10 by choosing Brisbane as the city on the Settings page. I have also installed the Sucuri WP Plugin v1.8.19 and used its Timezone setting to select UTC+10. However, the times shown by the Sucuri plugin aren’t correct.

    For example, I logged in as wp-admin at 16:30 on 2018-01-24 (local time, UCT+10) but Sucuri’s Audit Log showed it was Jan 25, 2019 06:30 and on the “Successful Logins (all)” page the Date/Time value for that login was “in 10 hours” i.e. in the future!

    Please tell me if there’s any way to fix that.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Hello @raywpa

    I apologize for the inconveniences setting the timezone.

    Dealing with dates in a distributed system is tricky. I’ve added the setting in the plugin because it was clear, after several attempts to fix this problem, that the WordPress setting was not working for the audit logs. There must be something somewhere in the code messing up the timestamps, probably removing the timezone tag, and so when the date is formatted it shows a different time because there is no timezone to translate.

    For now, I recommend you to set the timezone to +0 UTC. This is considering that the dates are showing up +10 hours ahead of time, and you configured the plugin to show the dates in UTC+10.

    Let me know if that works for you.

    Thanks for replying yorman.

    I’ve set the Timezone in Sucuri’s settings to UTC.

    Now when I log in to WP the message at the top of the WP Dashboard gives the correct time for my zone (I don’t remember if it was correct before the change):

    SUCURI: Last login was at January 25, 2019 11:10 am from xx.xx.xx.xx (xx.xx.xx.xx.domain.name.com) view all logs

    The Successful Logins (all) Date/Time value is “in 10 hours” but I noticed that hovering the mouse cursor over that value makes the correct time appear in a small floating box. Firefox’s Inspect Element functionality shows this code (it it’s of any use to you):

    <td>
    <span title=”2019-01-25 11:35:05″>in 10 hours</span>
    </td>

    The “Successful Logins (admins)” tab shows the correct Date/Time:

    January 25, 2019 11:35 am

    The Audit Logs tab on the Dashboard shows:

    Today
    05:35

    Which is a bit confusing. Let me know if you’d like more information and I’ll try to assist.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Sucuri Time Setting’ is closed to new replies.