Support » Plugin: Sucuri Security - Auditing, Malware Scanner and Security Hardening » Sucuri: (1456617115) Send_log: SSL connect error.

  • Resolved djsteveb

    (@djsteveb)


    I’ve seen this error so many times in so many places.
    Today it happened what I went to widgets, and changed a simple parameter (for pages listed, exclude pages, save)

    These types of errors have been appearing for quite some time in the admin dashboard for a variety of things. Of course I am concerned that things may not be saving correctly or causing other unknown issues with our site.

    Another concern is what the heck is sucuri doing sending logs anyway? Does this mean sucuri is sending data to third party servers? If so what data is being sent.

    I will post another thread about this as it’s a related but different issue.

    https://wordpress.org/plugins/sucuri-scanner/

Viewing 1 replies (of 1 total)
  • I am checking the connectivity issue with our infrastructure engineers.

    Regarding your question about the data that the plugin is sending to 3rd-party services, there is a message in the modal container that appears when your are going to generate the API key, and a highlighted note in the settings page with this text:

    Generating an API key implies that you agree to send the information collected by the plugin to the Sucuri API service which is a remote server where the information for the audit logs is stored, this is to prevent malicious users to delete the logs during an attack which may affect an investigation if you suspect that your website was hacked. We also use this information to display statistics and try to use the data in an anonymous way as we are concerned about your privacy too. Please do not generate an API key if you do not agree with this, you can keep using the plugin without it anyway.

    The data that you see in the “Audit Logs” panel located in the plugin’ dashboard is the data that is being sent to the API service. Additionally, we use some of that data anonymously to build this page [1] with statistics of how WordPress is being attacked in the wild.

    You can go to the “API Service” panel located in the plugin’ settings page and disable the communication between the plugin and the API service, this will force the plugin to stop sending data to 3rd-party servers if you disagree with that.

    [1] https://sucuri.net/security-reports/brute-force/

Viewing 1 replies (of 1 total)
  • The topic ‘Sucuri: (1456617115) Send_log: SSL connect error.’ is closed to new replies.