Support » Plugin: LifterLMS » Successfully enrolled in membership then told failed but seems to be enrolled?

  • Resolved mel4dia

    (@mel4dia)


    We have a free site where participants in a face to face course are manually enrolled by me – the course owner to access additional support materials.

    This has worked and been tested before, however things went weird today.

    The process we follow is:
    1) set up a user, then
    2) we enroll user in a membership, which automatically enrols them in 2 ‘courses’. This triggers an automatic welcome email which allows them to set (reset) their password.

    Today when adding people, I was told they were successfully enrolled. When the page refreshed, I was told the last person had ‘failed to enroll’, but this doesn’t look to be true.

    In testing with two users, they received the welcome email and could login – and I could see their names in the membership and courses user log and could also see their login date and time.

    Is this a ‘fail’ message that is coming in error?

    It has made me nervous as I can’t test whether the welcome emails have arrived for all my users. All I can do is wait for them to access the welcome email and set their password.

    Would someone mind getting back to me ASAP on this as we started a new program today and don’t want to embarrass ourselves with people losing faith in the LMS.

    thank you

Viewing 15 replies - 1 through 15 (of 16 total)
  • Sorry – just to be clear – I received the successful and fail message for the two users this has been tested with and yet it seems to have worked at their end and seems to have worked from my end?

    • This reply was modified 4 months, 3 weeks ago by mel4dia.
    Plugin Support Natalie

    (@nrherron)

    Hi @mel4dia,

    This may have come in error.

    If the emails were sent successfully and you have not received any further error messages then it may be a non-issue.

    However, if you can provide us with any screenshots of the message and your system report we can try and see if there could be any potential issues that triggered the failed message.

    More information on how to submit the system report and screenshots here: https://wordpress.org/support/topic/before-posting-you-can-help-us-help-you-by-following-this-guide/

    Let us know if you have any further questions!

    Thanks and take care,

    Thanks so much Natalie for replying – I really appreciate it.

    I’m not an experienced user of these forums or an IT person so wonder if it would be ok to email you the system report rather than post it here? I also have a screen shot of the error.

    I know it asks to attach things here and via dropbox but I’m nervous my inexperience might mean I share something that shouldn’t be public

    Kind regards, Mel

    Plugin Support Natalie

    (@nrherron)

    Hi @mel4dia,

    Unfortunately, we don’t really have a way for you to email us information!

    Right now if you could just send us the system report we can start there. If you use: https://pastebin.com/ this will let you edit out any email addresses you don’t want on the system report before you post it here. Other than that, the system report does not take any personal information (like passwords/usernames) from the site so it should be safe to post.

    Are you still receiving the fail messages when you test enrollment? If so, in lieu of screenshots can you provide us a step by step recreation of how you’re encountering this error so we can try to recreate it?

    Let us know if you have any further questions!

    Thanks and take care,

    Thanks Natalie

    Yes, I am still receiving the error fail messages. I saw participants in person today and all of them could access things so fortunately the error messages seem to be ‘fake’ ones but they still cause uncertainty that things have actually worked at my end.

    I’ve pasted the system report here and removed the email addresses.

    As mentioned above, this is the process we use:

    1) set up a user (and manually untick sending them the email about their account at this stage), then
    2) we enrol user in a membership, which automatically enrols them in 2 ‘courses’. This membership enrollment triggers an automatic welcome email which allows them to set (reset) their password. They get added to the two course lists.

    When I do this I get told this has been successful for XYZ person. Then I click on something else on the site and I get a fail message for that person. Words exactly are:
    Successfully enrolled XYZ in Membership name
    then moments later
    Failed to enroll XYZ in Membership name

    We tested this some months ago and no errors occurred. I started enrolling people in a new course last week and half way through the list these errors started.

    I wonder if this had any link to the problem? Our web guy Wes added some code to untick the automatic ‘sending them the email about their account’ part way through me adding my list of new users, in case I forgot to manually untick it. Soon after he made this change, I saw these errors. I got in touch with him to tell him about the errors so he took it back out. Even though he reversed this code the error still shows up even now.

    Here is the system report. I appreciate your help Natalie!

    WordPress
    ——————————————-

    Home Url: https://xxxxxxx
    Site Url: https://xxxxxxx
    Login Url: https://xxxxxx/wp-login.php
    Version: 5.1.1
    Debug Mode: No
    Debug Log: No
    Debug Display: Yes
    Locale: en_US
    Multisite: No
    Page For Posts: Not Set
    Page On Front:(#231)
    Permalink Structure: /%postname%/
    Show On Front: page
    Wp Cron: Yes

    Settings
    ——————————————-

    Version: 3.33.2
    Db Version: 3.33.2
    Course Catalog: Course Catalog (#15) [https://xxxxxxxxxxx/courses/]
    Membership Catalog: Membership Catalog (#16) [https://xxxxxxxxx/memberships/]
    Student Dashboard: Participant Dashboard (#18) [https://xxxxxxxx/dashboard/]
    Checkout Page: Purchase (#17) [https://xxxxx/?page_id=17]
    Course Catalog Per Page: 9
    Course Catalog Sorting: menu_order
    Membership Catalog Per Page: 9
    Membership Catalog Sorting: menu_order
    Site Membership: Not Set
    Courses Endpoint:
    Edit Endpoint: edit-account
    Lost Password Endpoint: lost-password
    Vouchers Endpoint:
    Autogenerate Username: yes
    Password Strength Meter: yes
    Minimum Password Strength: medium
    Terms Required: yes
    Terms Page: Terms & Conditions (#250) blanked out
    Checkout Names: required
    Checkout Address: required
    Checkout Phone: optional
    Checkout Email Confirmation: yes
    Open Registration: no
    Registration Names: required
    Registration Address: optional
    Registration Phone: hidden
    Registration Voucher: optional
    Registration Email Confirmation: no
    Account Names: required
    Account Address: required
    Account Phone: optional
    Account Email Confirmation: yes
    Confirmation Endpoint: confirm-payment
    Force Ssl Checkout: no
    Country: AU
    Currency: AUD
    Currency Position: left
    Thousand Separator: ,
    Decimal Separator: .
    Decimals: 2
    Trim Zero Decimals: no
    Recurring Payments: yes
    Email From Address: blanked out
    Email From Name: blanked out
    Email Footer Text: blanked out
    Blanked out
    Email Header Image: 7
    Cert Bg Width: 800
    Cert Bg Height: 616
    Cert Legacy Compat: no

    Gateways
    ——————————————-

    Manual: Disabled
    Manual Logging:
    Manual Order: 1

    Server
    ——————————————-

    Mysql Version: 5.6.44
    Php Curl: Yes
    Php Default Timezone: UTC
    Php Fsockopen: Yes
    Php Max Input Vars: 1000
    Php Max Upload Size: 2 MB
    Php Memory Limit: 256M
    Php Post Max Size: 8M
    Php Soap: Yes
    Php Suhosin: No
    Php Time Limt: 30
    Php Version: 7.2.20
    Software: LiteSpeed
    Wp Memory Limit: 40M

    Browser
    ——————————————-

    HTTP USER AGENT: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:68.0) Gecko/20100101 Firefox/68.0

    Theme
    ——————————————-

    Name: Beaver Builder Child Theme
    Version: 1.0
    Themeuri: http://www.wpbeaverbuilder.com
    Authoruri: http://www.fastlinemedia.com
    Template: bb-theme
    Child Theme: Yes
    Llms Support: No

    Plugins
    ——————————————-

    Akismet Anti-Spam: 4.1.2
    BackupBuddy: 8.4.15.0
    Beaver Builder Plugin (Pro Version): 2.2.3
    Beaver Themer: 1.2.3.4
    Code Snippets: 2.13.3
    Customizer Export/Import: 0.9.1
    iThemes Security Pro: 6.0.1
    iThemes Sync: 2.0.15
    LifterLMS: 3.33.2
    LifterLMS Labs: 1.5.2
    Limit Login Attempts Reloaded: 2.8.1
    Popup Maker: 1.8.6
    Popup Maker – Terms & Conditions Popups: 1.1.2
    TranslatePress – Multilingual: 1.4.8
    WP Migrate DB: 1.0.11

    Integrations
    ——————————————-

    BbPress: No
    BuddyPress: No

    Template Overrides
    ——————————————-

    Plugin Support Natalie

    (@nrherron)

    Hi @mel4dia,

    Thank you for the information and system report!

    There are a couple plugins I see that you have turned on that could be conflicting with this function. IThemes security and sync could be causing a miss fire where the Membership is actually accepting the enrollment but the sync is causing the error message. Additionally, you might want to try turning off Code Snippets to make sure any extra code is not affecting the site.

    The best way to troubleshoot this would be turning off all non-essential plugins temporarily to see if the issue goes away and then turn them back on one by one until the issue comes back.

    If this doesn’t result in any fixes then it may be something in the database. I see you’ve used the WP Migrate, which LifterLMS is not really set up to work with. Something may have gotten transferred in the migration that should be refreshed, but that would be the next troubleshooting method after checking plugin conflicts.

    Let us know if you have any questions on this process.

    Thanks and take care,

    Thanks Natalie – really appreciate these ideas.
    I’ve sent this to our web support guy Wes and he’ll look at doing the things you suggest when he is back at work next week. Will let you know how things go.
    Have a lovely weekend, Mel

    Hi Natalie

    Wes followed you steps but unfortunately the ‘error’ message remains when we add a new user and enroll them in a membership – just as before.

    He deactivated the plugins you mentioned. The one we guessed might be the cause was the code snippets one because the error started happening after Wes added some code to the user page to make the untick sending an email at this stage the default. He removed it once the error started happening. We thought something might be hanging around in the background so hoped it would disappear with deactivation of that plug in but no luck.

    He also deleted the code snippets plugin entirely but the ‘error’ remains.

    Any other ideas we can try?

    Plugin Support Natalie

    (@nrherron)

    Hi @mel4dia,

    Is this the only membership that this is happening on?

    You could try to create a second membership for testing and see if you encounter the same issue with enrolling test students there as well.

    If the issue is gone on the test membership then there may be something off about the configuration of the membership where you’re seeing this issue.

    Are you able to test this or should we look for another troubleshooting option?

    Thanks and take care,

    Hi Natalie

    Good suggestion – we tried that today but unfortunately the same ‘fake’ error message! The user can see the course attached that membership.

    Any other ideas?

    Plugin Support Natalie

    (@nrherron)

    Hi @mel4dia,

    It could be related to a Javascript error. There is some information here on diagnosing Javascript errors: https://wordpress.org/support/article/using-your-browser-to-diagnose-javascript-errors/#step-3-diagnosis

    If you could send us a screenshot or copy/paste us any Javascript issues you see we can help diagnose those.

    Let us know if you find anything, and thank you for your patience getting this resolved!

    Thanks and take care,

    mel4dia

    (@mel4dia)

    Hi Natalie

    There were no Javascript errors, and my web guy set up the error log on the site and nothing showed up that either when we tried enrolling our test user again. He said this means it’s not an error but some kind of glitch or bug.

    I’m not sure what else we can do. I suppose I’ll just have to ignore it – which isn’t really ideal.

    Thanks again, Mel

    Plugin Support Natalie

    (@nrherron)

    Hi @mel4dia,

    I apologize for the delayed response!

    There are a couple other things you could try to rule out conflicts but you’d definitely want to set up a staging site first: https://lifterlms.com/docs/staging/ so you can do things like switch off the theme and turn off all other plugins without affecting your live site.

    If there’s nothing showing up in any error logging, then I suspect there’s some kind of conflict somewhere that’s causing the message to pop up.

    I’m sorry we couldn’t find you a direct solution for this issue!

    Please let us know if you have further questions!

    Thanks and take care,

    Thanks Natalie – we’ll give that a go and let you know if we have any luck!

    No luck I’m afraid Natalie!

    Wes made us a staging site then we:

    Deactivated all plug ins except LMS. I tried in two browsers to ensure the browser wasn’t the issue

    In firefox – Deleted user, Added user
    Enrolled user on user page – successful message then unsuccessful message
    Did same in chrome and had same issues
    Also created myself a new user account in case this was the cause – but same issues.

    Decided different route – enrolling user in memberships page – get no message of any kind – ie no successful or unsuccessful!

    So….bug must be in Lifter LMS somewhere. Weird thing is Wes the web guy doesn’t get the message on his system – just me on mine, and my business partner on his laptop. In any account we use.

    Might be time to give up I think!

Viewing 15 replies - 1 through 15 (of 16 total)
  • You must be logged in to reply to this topic.