Support » Plugin: Woocommerce CSV importer » Successful Upload but products no where to be seen

  • ResponsiveLabs

    (@responsivelabs)


    Hey Guys,
    Thanks in advance for your support and putting together this app. I am running WP 3.8.1 & woo commerce 2.1.2. I have followed your tutorial word for word, matched all the headers (including post_title) and uploaded my file (22 products). It goes through the 26 lines one by one and returns a successful message “Done”. When I now go to products in woo commerce the freshly uploaded products are no where to be seen.

    Any help with this problem would be greatly appreciated.

    https://wordpress.org/plugins/woocommerce-csvimport/

Viewing 9 replies - 1 through 9 (of 9 total)
  • I have exactly the same problem, please help!!!

    Plugin Author allaerd

    (@allaerd)

    most of the time you would have wrong values for post_status, visibilty.

    remove those columns and try again.

    Hi

    I am having the same issues. My csv file is only 7 lines (for testing purposes)
    I set the header, and have also excluded post_status & visibility, but still gets to Done! and then no products imported

    Any ideas ?

    Thanks
    Marc

    I was having the same problem. I would load my test products under the import tab and it would go through the process but no products would show up afterwards.

    For some reason, I loaded my csv under the Header tab and after I hit the save button and then went back to the Import tab and loaded it again, it worked this time. Maybe that is an extra step that will make it work?

    Plugin Author allaerd

    (@allaerd)

    please check the post_status and visibility fields they probably have wrong values

    I have what I think is the same issue, post-status and visibility are correct (as per the info page of the plugin)but items do not show until they are opened in edit and saved (without needing to change anything) added to this I must open in ‘quick edit’ rather than ‘edit’ or the item will lose it’s price.

    now my problem is the shop has 13000+ items and I don’t have the time do this manually.

    I have the same problem.

    My export (from Quickbooks) doesn’t have a field for status or visibility, so I added fields to it with the values “published” and “public”, in case these do not default to “show this product” values.

    It shows it working through the rows, and says “Done!” but there are no new products in WordPress. I’m working with sample data, so I stripped out everything except the type, item, description, price and the two added fields. Still nothing.

    I’m out of ideas, but I like the interface, so I’m hoping this question will be addressed. Given that the product was last updated about the time this thread started, I’m wondering if there’s a bug?

    FWIW, my installation is a brand new Woocommerce installation with no prior products. Sounds like at least one guy above is also trying to work with a fresh install. How about the rest of you?

    I have found the issue with my import, it’s with the difference in terminology between Woocommerce exported CSV and the required terms for import via your plugin, very simple but apparently I missed it.
    Woo exports visibility for catalog & search as “catalog, search” but to get the same value on import I needed to use “visible”. this worked for me so hope it helps someone else.

    Same issue as everyone else on this thread. Uploaded a bunch of products but they don’t show up anywhere.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Successful Upload but products no where to be seen’ is closed to new replies.