WordPress.org

Forums

Contact Form 7
Success Message never shows up, only spinning (6 posts)

  1. DarylJohnson
    Member
    Posted 1 year ago #

    I have successfully updated CF7, but when I submit, the email sends, but the arrow keeps spinning and the validation message never shows up. I also have a redirection occurring, and it never gets to that either.

    Any ideas? thanks in advacne

    https://wordpress.org/plugins/contact-form-7/

  2. Ruby
    Member
    Posted 1 year ago #

    I am having the same issue. I installed the plugin two days ago and now will not send? I have also reinstalled plugin and still same outcome.

    *I only sent one test email to myself.

    *I read in other, older threads that it could be something to do with SMTP settings, but I do not see why this should be the case? I never had to do this before?

    So yes any ideas? Any help greatly appreciated?

    Cheers

  3. esmi
    Forum Moderator
    Posted 1 year ago #

    @RRandesi Design: It is considered impolite to interrupt another poster's ongoing thread unless you are posting a solution or suggestion. As per the Forum Welcome, please post your own topic.

  4. Ruby
    Member
    Posted 1 year ago #

    Oh sorry my apologizes this was my first post. >>> I didn't know I shouldn't comment if I didn't have a solution.

    But as of right now I kinda do. My company thinks it has to do with the new version. We are rolling back to last version. Something to do with the JavaScript.

  5. Ruby
    Member
    Posted 1 year ago #

    After interrupting the flow I hope this will help.

    This is my suggestion after research and testing. You can roll back to at least 3.8. This is what we did and now everything back to normal.

    The Conclusion:

    * Contact Form 7 - Stop at ver. 3.8.1 (DO NOT UPGRADE TO 3.9 - FREQUENT JS CONFLICT ISSUE)

    * Easy WP SMTP - Stop at ver 1.0.7 or backup setting information before upgrade (upgrade to 1.0.9 will erase the setting)

  6. buzztone
    Member
    Posted 1 year ago #

    @DarylJohnson - The spinning arrow is a common symptom of a Javascript conflict with either your current WordPress theme or one of the other plugins you are using - see Contact Form 7 Email Issues - there is a link there that covers Javascript Conflicts.

    The suggestion by Ruby is unlikely to be relevant to your situation.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Contact Form 7
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.