Subversion Commit Error: Authorization Failed (5 posts)

  1. Adrian Hanft
    Posted 7 years ago #

    I was approved to add my plugin to subversion yesterday. I was able to checkout just fine. I added my plugin to the Trunk, but when I go to commit the files I get the following error:

    Commit failed (details follow):
    MKACTIVITY of '/!svn/act/d5749782-a436-11dd-9113-89c9d1bb2864': authorization failed (http://svn.wp-plugins.org)

    I am using Versions on a Mac, but I get an error on commut using svnx also. I have seen people getting similar errors here on the forums in the past, but I haven't see and resolution. Does anybody have any suggestions or explanation of what I could be doing wrong? Thanks in advance for any help!

  2. xondie
    Posted 7 years ago #

    I'm having this issue too and have been trying for well over a week to get some assistance on it with no luck. Any help is appreciated.

  3. mcosx
    Posted 7 years ago #

    I get the same error. Did you solve your problem?

    I'm working on a Mac too. I've just tried it on Linux over ssh and it worked. So the problem seems to be mac specific.

  4. mcosx
    Posted 7 years ago #

    Few minutes later: I've just solved it. You have to remove ~/.subversion. After that you're able to commit with svn ci --username <name> --password <pass> -m "message"

  5. Hugh
    Posted 6 years ago #

    I am having the same problem. OSX.
    @mcosx are you using the command line? or svnX? I am using terminal and get the same error as described by adrian3. Where exactly is the "~/.subversion."? I would like to get this working with svnX or in the terminal.

    thanks in advance.

Topic Closed

This topic has been closed to new replies.

About this Topic