Support » Plugin: PAYMILL for WordPress » Subscriptions set to “inactive” after first renewal

  • Hi Matthias,

    I see you are working again on the Plugin (which is very, very good news!).

    We use WooCommerce Subscriptions 2.1.2 and Paymill 1.10.9. It works, except that after the first renewal (that is, 1st withdrawal of money) the Subscriptions’ Status are set to “inactive” at https://app.paymill.com/subscriptions

    If we try to manually activate the Subscription again (under https://app.paymill.com/subscriptions), then we get the error message (always and for all the inactive Subscriptions): “The subscription is not assigned to an active payment method. Please select an active payment method. After that you will be able to re-activate the subscription.” I can edit the Subscription then and save, but then again, when trying to “Activate” the Subscription I get the same error.

    The WooCommerce Subscriptions backend shows all these as “active”. We just started the Subscriptions feature one month ago. It is monthly, and we are worried that the money withdraw will now fail for the next (2nd) renewal on 1th of March.

    Kind regards,
    Gerd

Viewing 6 replies - 1 through 6 (of 6 total)
  • In particular, we really need to understand/know the following: The subscription’s status in WooCommerce shop backend is active, but in Paymill backend it is deactivated. So will the next money withdrawal (monthly, next on 1st March) work or not?

    Plugin Author straightvisions GmbH

    (@matthias-reuter)

    Please ask the support of Paymill directly to get information about why the subscription status was set in Paymill to inactive. This could be a bug in the plugin or in your configuration, but we need to get some information about the reasons from Paymill support.

    Hi Matthias,

    we already contacted Paymill via their support channel and are awaiting their answer.

    From your side it would just be good if you could reply to the following, because we do not know how this plugin’s trigger work:

    Because the subscriptions are active in WooCommerce Shop backend, is it possible that this plugin sends a trigger on 1st of month for money retrieval to Paymill and this will work despite the Subscription being ‘deactivated’ in the Paymill backend right now? To us the big question is: Will money withdrawal work on 1st of March. And Subscription being active in shop backend while being deactivated in Paymill backend is confusing.

    Plugin Author straightvisions GmbH

    (@matthias-reuter)

    Hi Gerd,

    WordPress is waiting for a renewal payment confirmation sent from Paymill via Webhook. This will renew the subscription in WordPress.

    Please ask the support why the subscriptions in your Paymill Dashboard have deactivated status right after first payment, as they should have the active status.

    Kind regards,

    Matthias

    Hi Matthias,

    we could now reactivate the paymill subscriptions using curl which works – whereas the Paymill management web interface did not work, probably a bug in the paymill web frontend.

    Anyway, together with the paymill support we also looked into the root cause of this issue, that is, why subscriptions are set to inactive in paymill after the first renewal. Support says that this is caused by an API request (from our wordpress site) to paymill to deactivate the subscription:
    > die Ursache für die Pause lag an einem API Request um 01.02.2017 03:01:48

    We agreed with the Support that we give you this information so you can look into the issue as the debug information should be available to you as well.

    As I said before, this is totally reproducable for all our subscriptions.

    In case you need more information, we might want to switch to email?

    Best,
    Gerd

    Plugin Author straightvisions GmbH

    (@matthias-reuter)

    Hi Gerd,

    thank you for the information. Could you send me an email to info@straightvisions.com

    We can switch to German then.

    Kind regards,

    Matthias

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Subscriptions set to “inactive” after first renewal’ is closed to new replies.