Support » Plugin: WooCommerce » Subscriptions Not Working after Update 3.0

  • Hello,

    Our site was updated to 3.0 automatically and now our subscription product isn’t a subscription anymore; all of our subscriptions were changed from automatic renewal to manual renewal.

    I have reverted to an older version; however, this issue wasn’t fixed. The subscription product was changed to a “Simple Product”. I have tried to save it as a “Simple Subscription”, but when I hit update the page doesn’t update.

    We also have the following error at the bottom of the woocomerce setting page:

    Fatal error: Call to a member function get() on null in /home3/bpure/public_html/wp-includes/cache.php on line 123

    Thanks in Advance,

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Mike Jolley

    (@mikejolley)

    Please put in a ticket for subscriptions support if you’re on the latest 3.0 compatible release https://woocommerce.com/my-account/tickets/

    Same thing happened to me, rolled back site from our repo… Won’t be updating for a while.

    Hey Guys, we’re having the same issue and restoring a backup isn’t really an option for us. Please let us know when any of you figure out what the problem is.

    This has happened to me, what a nightmare. All my subscriptions are not collecting which is a massive issue. I have restored the site from a backup and I hope this will work and I have also opened a ticket, but I only have 4 hours until my next lot of payments are due to come out.
    Customers are getting very confused by it all as they are receiving Paypal notifications that their account has been cancelled.
    Subscriptions just cannot fail – they are too important. Everything else can be fixed, but this has to be a priority surely?

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Subscriptions Not Working after Update 3.0’ is closed to new replies.