WordPress.org

Support

Support » Plugins and Hacks » Jetpack by WordPress.com » [Resolved] Subscription Widget Validation issue!

[Resolved] Subscription Widget Validation issue!

  • So the subscription widget has some issues. This is the validation errors that I get. The forms have Duplicate ID’s

    Line 732, column 75: Duplicate ID subscribe-blog.
    <form action=”” method=”post” accept-charset=”utf-8″ id=”subscribe-blog”>
    Line 731, column 25: The first occurrence of ID subscribe-blog was here.

    Line 732, column 75: Bad value for attribute action on element form: Must be non-empty.
    <form action=”” method=”post” accept-charset=”utf-8″ id=”subscribe-blog”>

    http://wordpress.org/extend/plugins/jetpack/

Viewing 4 replies - 1 through 4 (of 4 total)
  • Hi,

    I’m still getting the error, could you fix this? I believe it’s only a matter of putting action="#" instead of the current action="".

    Thanks

    Edit: Yeah I was correct, in jetpack/modules/subscriptions.php at line 584 (jetpack 2.1.2) you just have to replace:
    <form action="" method="post" accept-charset="utf-8" id="subscribe-blog">
    by:
    <form action="#" method="post" accept-charset="utf-8" id="subscribe-blog">

    Plugin Author Jeremy Herve

    @jeherve

    Thanks for the report. We’ll have a look at the issue, and I’ll get bac to you as soon as we can address this problem.

    Plugin Author Jeremy Herve

    @jeherve

    We have fixed the issue in r666993. The fix will be available in the next Jetpack release.

    Hi WordPress, I am encountering an error with my “Subscribe via email” social links widget on my website. When certain email formats are entered into this widget, the error will not allow these emails to be subscribed to my website. An error message appears stating “The email you entered was invalid, please check and try again”. This occurs, when indeed this is not an invalid email and should work. Please help me! My website is: velvetandvino.com

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘[Resolved] Subscription Widget Validation issue!’ is closed to new replies.
Skip to toolbar