Support » Plugin: Newsletter » Subscription mails

  • Resolved ale5000

    (@ale5000)


    Today, when the plugin updated to 5.1.5 in my mail that was in “unsubscribed” status to the newsletter I get 2 mails:
    1) [My site title] Newsletter subscription
    2) Benvenuto a bordo, {nome}

    And also that status has changed to subscribed without asking to do it.
    I hope that it doesn’t auto-subscribe all users without asking on all updates.

    Also why it say “{nome}” in the object of the mail?

Viewing 14 replies - 1 through 14 (of 14 total)
  • Plugin Author Stefano Lissa

    (@satollo)

    {nome} is an erro made by translators. The update does not check the user or sends emails so the email you got have been triggered by other means.

    Stefano.

    ale5000

    (@ale5000)

    The main problem is that the status got from unsubscribed to subscribed and I haven’t changed it.

    Plugin Author Stefano Lissa

    (@satollo)

    Hi, the only way to change the status is to follow a confirmation link, may be you followed it from an old email? For sure it was not related to the update, do you remeber other actions you toke, liket tests, subscription attempts, and so on?

    ale5000

    (@ale5000)

    I never subscribed or followed links regarding this.
    I have now set it again to unsubscribed and I will try to see if the problem happens again.

    Regarding “Benvenuto a bordo, {nome}” I don’t find it in the translation, can you please point me to where the string is located?

    ale5000

    (@ale5000)

    @satollo
    It happened again.

    Steps:
    – Disable the subscription from the admin interface
    – Close the browser
    – After some time login in the admin interface of WordPress, in the instant I login the subscription is re-enabled without asking and the mail sent (I can see by the date/hour of the notification mail that is the same)

    Note: The e-mail is the same of WordPress admin e-mail (not sure if it is related).

    Plugin Author Stefano Lissa

    (@satollo)

    Uhm, since we recently changes the confirmation process, I suspect there is a bug and you met it. That subscription is connected to your WP user and the login is confirming the subscription.

    I’ll check suddenly and release a patch. You have the wp users integration extension active, right?

    Stefano.

    Plugin Author Stefano Lissa

    (@satollo)

    Ok, could be a problem with the latest update and the wp_users integration. Have you enabled it? Do you receive the welcome email as well (if not disabled)?

    Stefano.

    ale5000

    (@ale5000)

    Yes, I have the wp users integration extension active and I receive the welcome email.

    Plugin Author Stefano Lissa

    (@satollo)

    Ok, bug found and we’re goingo to releae the patch

    Stefano.

    Plugin Author Stefano Lissa

    (@satollo)

    Enter the main setting panel, save and on plugins panel you should see the update notice.

    Stefano.

    Thanks, the problem of auto-subscription is fixed.

    Can you please give me some hint where to find the incorrect Italian translation “Benvenuto a bordo, {nome}”?

    Plugin Author Stefano Lissa

    (@satollo)

    I’ll check it myself it could be on translate.wordpress.org

    Plugin Author Stefano Lissa

    (@satollo)

    Anyway you can change every text on subscription configuration panel, what comes from official translation is only used to setup an initial configuration.

    Plugin Author Stefano Lissa

    (@satollo)

    I’ve checked, it is not part of the translations, probably it was uncorrectly setup in your blog. Evem inside our default values is used {name} as plsaceholder.

Viewing 14 replies - 1 through 14 (of 14 total)
  • You must be logged in to reply to this topic.