Support » Plugin: PowerPress Podcasting plugin by Blubrry » Subscription link is ‘invalid’.

  • Resolved T

    (@tenleftfingers)


    Hi folks,

    I’m getting complaints about the Android subscription link put in the footer of each post by Blubrry. I can confirm the issue on Firefox. Here’s an example of a message:

    “underneath each episode there’s a “Subscribe for Android” button

    https://subscribeonandroid.com/amigausers.ie/feed/podcast/

    But when you go there it doesn’t load, it gives an error
    “Invalid Feed. Feed must be in XML””

    Any idea why this URL doesn’t work?

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Support Shawn Thorpe

    (@shawnogordo)

    When I tried to load your feed:
    https://amigausers.ie/feed/podcast/

    I got a warning from Google Chrome that there was a problem with your site’s SSL certificate. I told it to load the page anyway, and when it did load, I was forwarded to a login page for your site’s SSL provider. I’d recommend fixing that and see if it clears up the issue with Subscribe on Android.

    Plugin Author Angelo Mandato

    (@amandato)

    Another option, if your site is not using SSL, you could use the non SSL version of Subscribe on Android to complement your non secure feed URL.

    e.g. http://subscribeonandroid.com/amigausers.ie/feed/podcast/ (works)

    The http:// version of subscribeonandroid.com is for non secure sites, while the https:// version is for secured sites.

    Thread Starter T

    (@tenleftfingers)

    Thanks guys. Tthe site doesn’t use SSL so my feed looks like this http://amigausers.ie/feed/podcast/

    As for using the http version of the links, from what I can tell they are created by Powerpress not me. Where do I tell Powerpress to generate the URL differently?

    Plugin Author Angelo Mandato

    (@amandato)

    It works automatically, if your feed is http then that’s the URL it uses, if it is https then it uses that one. I just checked an episode on your site (http://amigausers.ie/episode-4-1-kenny-gaughan-swos-ireland-champion-2017/) and it is using the correct URL to Subscribe on Android.

    Can you tell me where you found the https:// version of the URL on your site? Perhaps it is not PowerPress that is setting it?

    Thread Starter T

    (@tenleftfingers)

    I see http too now, and the link works (I get no feed error). So I’m wondering if my hosting company might be the problem.

    I got the https link by email letting me know about it. I was able to reproduce the error but can’t remember now if I also had https or http.

    • This reply was modified 5 years, 1 month ago by T.
    Plugin Author Angelo Mandato

    (@amandato)

    Hello @tenleftfingers,

    If the site was temporarily setup with https:// that would explain where it came from. Eventually you may want to get https setup as it helps with google search, if that is a concern. There are free SSL certs you can use but be careful to pick one that works with iTunes. LetsEncrypt since the beginning of this year is now supported by Apple and it is free. Here’s a full list with details: https://create.blubrry.com/manual/your-web-site/secure-ssl-podcast-website/

    Thread Starter T

    (@tenleftfingers)

    Hi Angelo,

    Thanks so much for the extra info. I didn’t know iTunes compatibility was something to think about when selecting SSL certs. The site has never had SSL and my host didn’t support LetsEncrypt when I last asked, but I’ll look into it again.

    The link is still working fine so I’ll put it down to a glitch with my server and close this.

    Thanks & regards

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Subscription link is ‘invalid’.’ is closed to new replies.