Support » Plugin: YITH WooCommerce Subscription » Subscription is not working for stripe or paypal payments

  • Hi,

    I have set up one month subscription for Stripe and Paypal payments but reoccurring payments are not working.

    Payment works for the first time, but then when its time for next month the payment didn’t work automatically.

    Will system create automated notification to client for doing the payments? Or will stripe or papal handle this? Should this be enabled at Paypal or Stripe end?

    I have used – WooCommerce Stripe Gateway (from woocommerce ) plugin for stripe
    and Woocommerce (from woocommrce) basic plugin for paypal

    Please let me know if you need any further information.

    Regards,
    Manjeet

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • FYI
    I am using free version of the YITH WooCommerce Subscription plugin.

    manjeet1

    (@manjeet1)

    Hi,

    Also stripe is sending error emails:
    Stripe webhook delivery issues for https://theproptrading.com.au

    Could you please let me know how to fix this?

    Below email message says:
    You need to return anything between a HTTP 200 to 299 for the webhook to be considered successfully delivered.

    Could you please let me know how can i check if its 200 success message.

    Thanks

    ———————————————–
    The email message is below:
    Hi there,

    We’re contacting you because we’re still having trouble delivering data to a webhook endpoint associated with your theproptrading.com.au account in live mode. Webhooks are used to notify your server about events that happen in your Stripe account, such as a payout completing or an invoice being created. The failing webhook endpoint is https://theproptrading.com.au/?wc-api=wc_stripe.

    You or someone on your team has added that endpoint in your Stripe webhook settings, which you can view and edit here: https://dashboard.stripe.com/account/webhooks.

    Please note that in most cases a failing webhook does not impact your payments or payouts. However, if you use subscriptions we rely on your webhook endpoint to notify you of new invoices. These invoices may be delayed for up to three days if your webhook is unable to successfully receive them. If you use Checkout, you may be handling the checkout.session.completed event as part of your purchase fulfillment process as described here: https://stripe.com/docs/payments/checkout/fulfillment#webhooks. If you do, failure to handle these events may interfere with purchase fulfillment.

    We’ve attempted to notify the endpoint 164 times since June 23, 2020 at 12:29AM. If this endpoint is important to your application, please try and fix the issue. If you do not need the webhook endpoint you can delete it from your Stripe webhook settings. We will stop sending notifications to your webhook by July 2, 2020 around 12:29AM.

    Here is the summary of errors we have received when sending you webhooks:
    * 164 requests had other errors while sending the webhook.

    You need to return anything between a HTTP 200 to 299 for the webhook to be considered successfully delivered.
    For more details on the errors, you can find your events page here: https://dashboard.stripe.com/events.

    You can also always review the history of webhooks and failed request logs right from your dashboard: https://dashboard.stripe.com/events.

    This email is the last time we’ll reach out to you before disabling the webhook.

    For more in depth information about how to use webhooks, we recommend taking a look at our documentation: https://stripe.com/docs/webhooks.

    Yours,

    The Stripe team
    —————————————————————–

    Hi,

    Could you please check this as we stripe is getting 400 error when trying to access webhook to do subscription payments.

    Thanks

    Stripe is getting 400 error code at their end when trying to create subscription payment.

    Also there are few errors in the error log as below:

    2020-07-05T01:20:33+00:00 DEBUG
    ====Stripe Version: 4.5.0====
    ====Start Log====
    Stripe Payment Request live mode requires SSL.
    ====End Log====

    2020-07-05T01:20:38+00:00 DEBUG
    ====Stripe Version: 4.5.0====
    ====Start Log====
    Stripe Payment Request live mode requires SSL.
    ====End Log====

    2020-07-05T02:12:35+00:00 DEBUG
    ====Stripe Version: 4.5.0====
    ====Start Log====
    Could not find order via intent ID: pi_1H1NL5BwBs8kYSPUBWnQuNYe
    ====End Log====

    SSL is enabled on the whole website.
    And can you check what is the issue with – Could not find order via intent ID

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.