WordPress.org

Ready to get started?Download WordPress

Forums

Subscribe2
Subscription form always redirecting to homepage despite changing settings (12 posts)

  1. tactics
    Member
    Posted 8 months ago #

    When a user subscribes, I don't want them to leave the page, I just want them to get the confirmation dialog. I've tried setting the post form content to both "use referring page" and "use homepage", but neither works. It always redirects to the homepage. Site is here:

    http://fashionistador.com

    https://wordpress.org/plugins/subscribe2/

  2. mattyrob
    Member
    Posted 8 months ago #

    @tactics,

    Just tested and it worked fine for me. You can turn off the AJAX feature in the Appearance section of the settings too, you don't need it when you use the full form on the page already.

  3. tactics
    Member
    Posted 8 months ago #

    Nope. Still doesn't work. From the home page, go to a post like this one:

    http://fashionistador.com/the-deanarita/

    Enter your email address in the sidebar or footer. The form redirects to the home page. It's supposed to just give the person a confirmation, and remain on the post page. Tested in Safari 5.1.1

  4. tanaylakhani
    Member
    Plugin Author

    Posted 8 months ago #

    @tactics

    Did you try disabling the AJAX?

  5. tactics
    Member
    Posted 8 months ago #

    When I disable Ajax, it still jumps to the home page. Only difference is that they don't get the notification popup (which makes it even worse).

  6. mattyrob
    Member
    Posted 8 months ago #

    @tactics,

    The issue is coming from your theme some who - the URL in the address bar does not change but the content does, so your theme must be altering it's behaviour somehow if content is posted in a form. Try with a core WordPress theme and I expect the redirect will stop happening.

  7. peter-a
    Member
    Posted 7 months ago #

    I'm having the same problem. I see that the topic is marked as resolved, but I wonder if tactics actually managed to get it working.

    @tactics, are you by any chance using a WooThemes theme?

    @mattyrob, any suggestions about how to figure out exactly what in my theme might be causing this?

  8. tactics
    Member
    Posted 7 months ago #

    No, I did not get it working, and it's not resolved. I'm using a WPExplorer theme.

  9. peter-a
    Member
    Posted 7 months ago #

    Does your theme include some kind of subscribe functionality, by any chance?

    Mine does, and I think there may be some kind of clash of variables or something.

  10. tactics
    Member
    Posted 7 months ago #

    No.

  11. mattyrob
    Member
    Posted 7 months ago #

    @peter-a,

    The first thing to check us to make sure it's a theme issue by changing to a core WordPress theme like Twenty Fourteen and seeing if the issue resolves. If it does I'd start looking in the functions.php file of the theme.

  12. peter-a
    Member
    Posted 7 months ago #

    It turns out that in my case it wasn't a theme issue at all — the redirect has to be set in the widget, not just in the plugin settings. Once I changed this to the right place in the widget's settings, it worked perfectly.

    @tactics, how about you?

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.