Support » Plugin: Easy Forms for MailChimp » Subscription fails and errors in admin

  • Resolved aklapwijk

    (@aklapwijk)



    Hello,

    We’re having an issue where users are unable to subscribe. The issue tends to appear and disappear a multiple times a day on our production server, https://wearesure.io/.

    If you try to subscribe during the time when the issue is ‘active’ you always get a success message, but no data is send to MailChimp.
    If you then go the Easy Forms admin panel, there are often some elements missing that should have been there. For example, if you click on one of the Opt-in forms the sidebars on the right may have disappeared and the “Form builder” panel on the bottom shows this message:

    Select fields from the right to add to this form, you can click a field to reveal advanced options, or drag it to re-arrange its position in the form.

    We’ve encountered an error. Reload the page and try again. If the error persists, please reach out to support.

    Reloading the page doesn’t solve it.

    I’ve tried re-saving the API key during the time we were having this issue. This resulted in an error (cURL Error 7) and the green “Connected” tag switched to grey “Not Connected”. When I tried the same thing (using the same API keys) on our test and development servers there was no error and the API stayed connected.

    CURL Error 7:(Page: Settings Page/General Settings || Type: Connecting to MailChimp)

    There are some errors in the server error log file as well:

    FastCGI: server "/var/run/php-fpm/php70/php-cgi" stderr: PHP message: PHP Warning: Illegal string offset 'data' in .../wp-content/plugins/yikes-inc-easy-mailchimp-extender/admin/partials/menu/manage-forms.php on line 256, referer: https://wearesure.io/wp-admin/admin.php?page=yikes-mailchimp-edit-form&id=1

    FastCGI: incomplete headers (0 bytes) received from server "/var/run/php-fpm/php70/php-cgi", referer: https://wearesure.io/wp-admin/admin.php?page=yikes-inc-easy-mailchimp

    Maybe the issue has something to do with the combination of the server and plugin? On our local development server and test server we never experienced any issues.

    To make sure we’re not losing subscribers we’ve written some code to log subscribers just before data should be transmitted to MailChimp. So even if the subscribtion fails, we are able to add them manually to MailChimp.

    Do you have any ideas on why this issue appears and how to solve it?
    Any help is much appreciated

    Thanks,
    Anne

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Contributor Jeremy Pry

    (@jpry)

    Hey Anne,

    Thanks for reporting this error. I think I might have an idea about what’s going on here. If the API happens to time out when attempting to retrieve data from MailChimp, that could cause the error that you’re seeing. We can make an update to handle that possibility more gracefully.

    Regardless of how the timeout is handled, it’s possible that your server needs a bit more time to attempt to make the request before WordPress determines that the request has failed. To that end, I’ve made a plugin that you can install that will increase time time limit to 45 seconds instead of only 10 seconds. You can download the plugin from here: https://github.com/PrysPlugins/Increase-Yikes-MailChimp-API-Timeout/releases/tag/v1.0.0.

    Hi Jeremy,

    Thanks a lot for your help! I’ve installed your plugin and everything works great so far.
    It does seem that the production sever needs a bit more time for requests compared to our test and dev servers. I will keep a close eye on wearesure.io today to see if it keeps working. Hopefully it does.

    Thanks,
    Anne

    Hi again,

    Yesterday someone had tried to subscribe at 16:37 (UTC+1), but the subscription wasn’t successful. When I tried to subscribe myself this morning it still didn’t work. In the admin area I encountered the same issues as described in my first post as well.

    When I look into our MailChimp account at the API keys page, the last API call with the user agent ‘WordPress/4.6.1; https://weare‘ was yesterday at 2016-11-08 14:45:09 GMT.

    Unfortunately the increased timeout didn’t solve our issue.
    Do you have any other ideas?

    Thanks,
    Anne

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Subscription fails and errors in admin’ is closed to new replies.