Support » Plugin: Jetpack by WordPress.com » Subscription confirm email uses WordPress install URL

  • Resolved domgreves

    (@domgreves)


    Hello. The automated subscription confirmation email provided by Jetpack displays a link to our website at the top of the email:

    “Please confirm your subscription for [website title here]”

    The text correctly displays the title of our website but the URL attached to the link points to the location of our WordPress installation. This is not shared with our website home page or our blog however.

    How do we customise this URL to point to the correct location?

    Thanks.

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Contributor James Huff

    (@macmanx)

    Volunteer Moderator

    The email subscription system runs through WordPress.com, which is why the confirmation email is directed in that manner. It is not possible to change this.

    Oh dear. It appears this plugin is fundamentally broken for anyone in our position in that case. Do you have any suggestions for working around this problem? WordPress.com uses the ‘WordPress Address (URL)’ from the ‘General settings’ menu, is that correct? I can’t find this documented anywhere.

    Plugin Contributor James Huff

    (@macmanx)

    Volunteer Moderator

    Hm, are you sure you’re using our subscription system?

    The subscription confirmation links in our confirmation emails go to:

    https://public-api.wordpress.com/bar/?stat=groovemails-events&bin=wpcom_email_click&redirect_to=https%3A%2F%2Fsubscribe.wordpress.com/[a-unique-and-long-string]

    Which winds up at:

    https://subscribe.wordpress.com/?email=[the-email-address]

    Plugin Contributor James Huff

    (@macmanx)

    Volunteer Moderator

    Wait … sorry

    The automated subscription confirmation email provided by Jetpack displays a link to our website at the top of the email

    Now that I’ve re-read that, yes the link at the top of the emails uses the Site Address (URL) set at Settings > General in your site’s Dashboard.

    We have just not have that synced properly on our end for you site. What is your Site Address stored as, and just to be sure, is it the same as the URL of your site?

    Our ‘WordPress Address (URL)’ is:

    Our ‘Site Address (URL)’ is:

    Our WordPress installation address is not intended to be public.

    • This reply was modified 2 months, 2 weeks ago by James Huff. Reason: links removed
    Plugin Contributor James Huff

    (@macmanx)

    Volunteer Moderator

    Ah, that’s the problem, we have both your Site and WordPress address the same in our system.

    Please try disconnecting Jetpack from WordPress.com at Jetpack > Dashboard > Site Connection > Manage Site Connection in your site’s Dashboard, then connect again when prompted.

    If that doesn’t work, please try deleting Jetpack specifically from the Plugins section of your blog’s Dashboard: https://jetpack.com/support/reconnecting-reinstalling-jetpack/#reinstalling-jetpack

    This will clear out Jetpack’s settings, and it should work properly after a reinstall.

    And, finally, if that doesn’t work, please reach out to us via https://jetpack.com/contact-support/?rel=support so we can take a closer look.

    We tried disconnecting and reconnecting but it is still using our ‘WordPress Address (URL)’ in the confirmation email.

    If we try uninstalling Jetpack plugin what data will be lost?

    OK, we tried deleting and reinstalling the Jetpack plugin but it is STILL using the ‘WordPress Address (URL)’.

    Plugin Support fresatomica

    (@fresatomica)

    In that case, it’s best to open a ticket via https://jetpack.com/contact-support/?rel=support. We’ll have a closer look and get back to you.
    Thanks!

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.