Support » Fixing WordPress » Subscribers Not Receiving New Post Notifications

  • I am beyond frustrated at WordPress right now. I help manage my company’s blog. There is one post that I have been trying to send out for over a week now, and it posts correctly, but subscribers are not receiving the notification.

    I tried putting out another post on Monday, and it worked just fine. So basically, I don’t know what the problem is with this particular post. My social subscribe2 settings are correct. Every time I notice that it does not send out the notification, I trash the post and then try again. I have cleaned out my trash, and I have tried renaming the post in case the system sees the title and thinks it is a trashed post.


Viewing 8 replies - 1 through 8 (of 8 total)
  • Rather than trashing and starting again try reverting the post to draft and hitting publish again.

    Without more details its difficult to tell why this is happening. Check, check and check again on those settings. Is the new post a post or a page, is there a password or is the post marked as private? Is it going into an excluded category? All of these may result in a failed delivery.

    I am seeing this same issue in the first post I’ve done after upgrading to 3.0. The “send a message” feature is functioning, so I used that as a workaround.

    Same here…running a fresh installation of WP3 and using custom post types (with Category taxonomies enabled). Send message works, as the above poster mentioned. But automatic emails are not being sent out when a new entry is posted.

    I should also mention that I am attempting to use a custom post type with a subscribed category. For some reason this does not work. Do you know what I might need to change within the plugin or within my functions.php to get subscribe2 to recognize new posts from within a custom post type?

    Email notification of new posts is not working after I activated and set up ‘Subscribe2 For Social Privacy’ plug in. My hosting company tech support was able to test the plugin and the email notification works just fine. Have spent hours trying to figure this out but failed…my tech support could not figure out either why.

    Any one can help??? Much thanks ahead.

    Have you guys tried installing email-log plugin?

    It adds a log step to every wp-mail call. So if there is a log entry there then you know that Subscribe2 has done it’s bit and called wp-mail.

    Remember that if you have #recipients set to zero (unlimited), it will probably only show the admin user. To debug, you could try setting the number to 1 – then each recipient will be listed in the log.

    If email and recipient not in log, then you know there must be some criteria somewhere stopping a post from being emailed. As noted above, it could be something about the post, the category, or maybe the users are not subscribed to that category – pick some users at random in the ‘subscribers’ list, click edit and see what categories are ticked.

    If emails are in the log, then you know the problem is elsewhere, not in the plugin. The rest is then up to wp, then php etc…
    and of course there are a myriad of reasons why some users may not get emails.

    Some reasons

    Hope that helps


    A million thanks for your post.
    I have spent hours and hours trying to figure this out.
    Now email notification is working!

    What had prevented it from sending out emails
    was that when I was adding a new post, I had ‘HTML’ mode
    on. After I switched to ‘Visual’, it started working.

    The email log plugin is a great tool.
    Thanks sooooooo much!



    Currambena your tips worked well especially the one about setting recipients to “1”.

    My problem seems to be that my users do not have their email format preferences set. When I set a couple of users manually (to full plain text) they received emails.

    How can I set all my users to full plain text emails?

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Subscribers Not Receiving New Post Notifications’ is closed to new replies.