Support » Plugin: MC4WP: Mailchimp for WordPress » Subscribers not added

  • Resolved dariasukova

    (@dariasukova)


    I created a form with the plugin but when I test it with my own email address it’s not working. I’m getting a message that my subscription was successful but I’m not added to the list. I enabled logs for everything and it shows that the email address was successfully added. However, I don’t see it on the list in Mailchimp and when I try to submit it again, I’m getting the same message. Double out-in is disabled.

    [2019-12-21 15:48:41] INFO: Form 367 > Successfully subscribed sibe*******@gm***.com
    [2019-12-21 15:50:09] INFO: Form 367 > Successfully subscribed sibe*******@gm***.com

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Contributor Lap

    (@lapzor)

    This means that the email is send to MailChimp successfully and the form is working as it should.

    Maybe double opt-in is turned on for this form under the form settings in the plugin? If so the email will only show in the selected list once the email is confirmed with the double opt-in link. Note that the opt-in settings are per form in our plugin and any settings in your MailChimp account regarding double opt-in are ignored.

    If that’s not it please share a link to where I can test the form for you.

    Hope that helps. If you have any questions, please let me know!

    dariasukova

    (@dariasukova)

    Thank you for the info! I did have double opt-in enabled in the form but for some reason emails were not coming through before. I just got them all at once this morning, from my previous tests. Thanks for your help, it’s working now!

    Plugin Contributor Harish Chouhan

    (@hchouhan)

    @dariasukova,

    Thanks for the update.
    .
    P.S. If you could spare a moment and leave a review for us at https://wordpress.org/support/plugin/mailchimp-for-wp/reviews/?rate=5#new-post, it would make us happy :).

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.