Subscribers can't log in (5 posts)

  1. Princess_Giggles
    Posted 7 years ago #

    This isn't a consistent problem, but it is an annoying one.

    I ask people to register and log-in before commenting. Twice in the last week or so two different commenters have tried to log-in to leave a comment, but the log-in screen takes them back to the blog without them being logged in. One tried to log-in through my meta list on the sidebar and got to the dashboard, but then when she clicked to visit the site she wasn't logged in any more. She was able to do some back door things, but I can't expect my mom to figure out back door log-in tricks.

    Again, it isn't consistent. The first subscriber hasn't had that problem again and has commented since. And my mom hasn't had the problem before today but as commented in the last week or so.

  2. Princess_Giggles
    Posted 7 years ago #

    This problem is back. And I have no idea what is causing it.

    I am running WordPress 2.7.1
    Platform Type: Debian
    MySQL Version: 5.0.45
    Perl Version: 5.8.8
    PHP Version: 4.4.7

    What's going on?

  3. jamesb4551
    Posted 7 years ago #

    It happens to my blog at times too, subscribers are using the same login details as emailed to them and then being denied to login, or redirected to the same page without being logged in. Any Ideas WordPress brethren's?

  4. datamafia
    Posted 7 years ago #

    Full on ditto here. Looking for a simple solution. New subscribers are not logging in ver 2.8.2.

    I have been sniffing actions and other data and I am stumped.

    Other roles have no problem.

  5. datamafia
    Posted 7 years ago #

    Here is some information that could help, or at least should be put in the open more.

    I was var_dump()-ing the $current_user and I noticed that $current_user->user_level is not set or even in the object/array. I don't know if this is a bug or not. I was hooking off of this and getting great failures. Subscriber should be user_level 0, right?

    So, if you, or a plugin / function / etc is hooking off of this and subscribers are in the mix you should be getting (silent) fail.

    There is this boolean in the $current_user called "level_0" - so that is (probably) a clear hook available.

    Feedback welcome, I consider this a bug, but I am not sure on the intent or implications.

Topic Closed

This topic has been closed to new replies.

About this Topic