Support » Plugin: Subscribe2 » 'Subscribe2_List_Table' not found

Viewing 15 replies - 16 through 30 (of 33 total)
  • @tomiga,

    Sorry about the delay, I type in the svn commit command and walked away, came back an hour later to notice the command had an error and hadn’t processed!

    Glad you checked back and thanks for confirming the fix.

    I have the same problem after upgrading WordPress 3.5

    Is the same fix as above then relevant.



    If you have the exact same problem then this fix should work fine for you.

    Hey Matthew

    All fixed. Seems it was probably an update by my host to PHP that caused the problem that I only noticed after upgrading WordPress to 3.5.
    The subscribe2 development version fixed the problem.

    Donation sent!!


    I’m glad the fix worked for you and thank you for your donation.

    I did loose my subscribers though. Probably something I did as I am a complete novice.
    No big deal though as there were not many, mostly all registered users that remained untouched and it was easy to re-subscribe the unregistered subscribers.


    I suspect you uninstalled the plugin from the admin area in WordPress.

    It’s always worth running a backup plugin. You hosting provider may be able to restore to a previous database also.

    So, I’ve tried all of these techniques, including downloading the developer version and uploading that version am still having the issue.

    It’s weird as sometimes the subscribers page 1 or 3 or 4 etc pulls up just fine, and then when you refresh it stops and gives me that:

    Fatal error: Class ‘Subscribe2_List_Table’ not found in /mnt/target06/346262/394688/ on line 136

    but for example, even when writing that, I went back and refreshed and the subscribers pulled up just fine.

    Does anyone have any ideas?



    Have you got some form of caching running on the server? It really should not run on the Admin side or you’ll get lots of weird things like this happening.

    Not sure actually. there is a WP-super cache they have installed on it that might be the issue. I’ve disabled it but am still having the issue.

    I also suspect it’s a caching issue now since it sometimes works when you refresh.


    Even though you have now disabled it, the server may still be serving cached pages if there were changes made in the .htaccess file for example.

    Have a check and see if there is a way to reset the Cache before disabling the plugin.

    If you need caching, I use one called Hypercache without any issues on my production sites.

    I did an upgrade to 8.6 and also have the list error. I also am seeing a {PERMALINK) error where that is not being output in emails.

    I will try the fixes above to see if I can get to my subscribers list.

    (Fatal error: Class ‘Subscribe2_List_Table’ not found in /home/weaver/public_html/wordblog/wp-content/plugins/subscribe2/admin/subscribers.php on line 136)

    I upgraded with the developers version that you had recommended above, it work re the subscriber list. I now can see all of them and do not get the error.

    I did not lose any of the subscribers.


    @mattyrob. So, I’m still on the hunt to get my client’s issue fixed. I am not really sure where the disconnect is for the WP-cache plugin and gong to the subscribers page. I just can’t figure out which plugin is causing the disconnect…. I’ve tried a few things to delete the cache on the wp-cache side and going back to the subscribe2 plugin, but nothing seems to change it and I still get that fatal error message.

    The only thing that works is just to sit on that page for a bit (when you get the error) then refresh and the content pulls up fine… so weird. I can’t really have that be a solution to the client though haha

    So I guess, as the author of that plugin, do you know if there is anything I could possibly do to get it so that the cache doesn’t run into the subscribe2 side of things? I dunno.

    hope you’re all having a good weekend!


    According to what I’ve just read about WP-Super-Cache it should not be working for users who are logged in (so basically it won’t be working on the admin pages).

    That doesn’t really explain why you are seeing this weird behaviour though.

Viewing 15 replies - 16 through 30 (of 33 total)
  • The topic ‘'Subscribe2_List_Table' not found’ is closed to new replies.