WordPress.org

Support

Support » Plugins and Hacks » Subscribe2 not sending emails

Subscribe2 not sending emails

  • I am running WordPress 3.2.1 and PlatformPro. Things were function perfectly for 6 months and then two weeks ago Subscribe2 stopped working. We had made no changes to the site at all. We have implemented some of the steps suggested on this forum including Restrict the number of recipients per email to 1, removed the plug in and re-installed in manually. Still it is not functioning. HELP!!

    This is our site: http://www.dirtandseeds.com

    Thanks.

Viewing 15 replies - 16 through 30 (of 90 total)
  • I installed 6.5 and it doesn’t work. I’ve called GoDaddy 3 times and nothing. The first time I had someone very interested in my problem and try to help, but nothing. The nextt two said it was not GoDaddy’s issue.

    I’m migrating off GoDaddy to a new host. I will let you know how it goes.

    MattyRob….done hassling with them.

    I have a client with the same issue. GoDaddy.com is the host. My client is not interesting in changing hosts at this time. Has anyone found a fix for this yet?

    I’m going to put the development version of Suscribe2 on the site. Is there anyway to upgrade to the development version with first deleting the current version? I know I can backup the subscriber list and then input the subscribers again after changing version. I’m just wondering if there’s a cleaner way to change versions without it being an official upgrade release.

    I’ve done some Googling for you all.

    It seems that GoDaddy have the following rules from what I’ve found:

    1/ The “From:” email address CANNOT be a gmail, yahoo, hotmail, aol, msn etc email address – if it is then the email will get dropped as spam.
    2/ The “From:” email address is best set up as an address on the same domain as your sire – so if your blog is http://www.example.com you need an address like info@example.com
    3/ The “info@example.com” email address given in the example above MUST actually exist on your domain. You may need to create this email.
    4/ You can only send to 250 or 1,000 different email addresses in 24 hours, any more unique addresses than that will be blocked. (I’ve quoted 2 numbers as I’ve found references to both – the lower seems more recent too)
    5/ PHP mail() function is totally unsupported on Windows IIS hosting, you must be on Linux.
    6/ It may be worth channeling your emails via the relay-hosting.secureserver.net server using something like the SMTP Mailer plugin.

    @adlinni,

    If you want the Dev version download it from here:
    http://downloads.wordpress.org/plugin/subscribe2.zip

    Unpack the zip on you home computer. Lig into your site using FTP software (try the free FileZilla if you are new to this).

    Find the wp-content/plugins/subscribe2 folder and rename it. Then upload the files you unzipped on your computer to a new subscribe2/ folder.

    Log into WordPress and make sure it’s all there and actives okay – then you can erase the folder you renamed.

    All that said, others have tried this I think it is hasn’t helped but feel free to have another go! 🙂

    I don’t have ftp access to clients server at this time. They’ve currently only given me access to their wp-admin. So I was wondering if there was a way to upgrade from the admin panel. But, no worries, I won’t mess with it if the dev version has not solved the problem for anyone.

    Any word on this GoDaddy issue being fixed? Or a work around to bypass whatever is they changed that’s causing the problem?

    We moved the site from GoDaddy and things are working perfectly. GoDaddy, through a process of elimination, was the culprit.

    @adlinni,

    There’s now way other than FTP as far as I know.

    @wayside,

    Thank you very much for confirming that it’s GoDaddy, this was starting to drive me insane!
    If anyone can find out from them the exact reason why Subscribe2 emails are being blocked then I’ll see if a fix can be applied to comply with the new restriction.

    Well, for now I’m going to give the smtp mailer solution a try. I’ve got it all set up and the test emails seems to be working fine. I’ll report back when a post is actually published, probably on Monday, then I’ll know if this solution is working.

    One thing I noticed, not sure if this helps narrow down the issue… but when a new subscribe signs up, the confirmation email went out just fine. I tested that a few times before setting up the smtp mailer. So it seems like it’s just the post notification emails that are being blocked.

    Thanks MattyRob!!
    I have several clients whom to test this out with…. I will post the results in the next 48 hours or so…
    The Subscribe2 plug in is fantastic and one of the staples of any decent web presence. I thank you for doing this research and I have my fingers crossed that we have isolated the problem….
    I spent some time with Go Daddy too… they were unable to isolate the reason for emails not going through with me…and suggested running it thru their SMTP so they could troubleshoot further with that.
    FYI

    thanks again

    I’m completely stumped on this one. I’ve setup “wp mail smtp” plugin to use relay-hosting.secureserver.net. I can send test emails just phone from the smtp plugin, so everything seems to be working fine there. Also if I subscribe as a new public subscriber then I receive the confirmation email from the subscribe2 plugin. So that seems to be working. But when I publish a new post the post notification email is still not sending.

    @mattyrob

    Thank you for all the helpful input so far, but for some reason I’m still stuck. Any other suggestions?

    Adlinni…try this. Go into your admin control panel. Under “Subscribers” pick any subscriber at random, chose the “edit” link and see if any of your site’s “Categories” are checked off. I found that when I upgraded none of my subscribers had any categories checked…I had to go back in and manually check the “check all” box for each subscriber. This task can be made somewhat easier by just holding down the Control key when you click on “edit” and open up a new tab for each subscriber. It’s then simply a matter of clicking one button on each tab. Don’t forget to save the changes for each subscriber.

    @wayside

    Thanks for the suggestion, but is this only for Registered Users? All the subscribers for this blog are Public Subscribers and I’m not seeing an option to edit.

    @adlinni…yes, this worked for Registered Users. I’m not certain how Public Subscribers interface with Subscribe2. The only way folks receive updates on my blog is to register. They are automatically subscribed when they fill out the registration info but are given the option of unsubscribing. Now that I have moved away from GoDaddy it seems to be working perfectly.

Viewing 15 replies - 16 through 30 (of 90 total)
  • The topic ‘Subscribe2 not sending emails’ is closed to new replies.
Skip to toolbar