Support » Plugin: Jetpack - WP Security, Backup, Speed, & Growth » subscribe to comments not showing

  • Resolved roeeyossef

    (@roeeyossef)


    Hi Guys,

    Seems as the subscribe to comments checkbox is not showing anymore. Not sure since when but it was working in the past without issues.

    Checkbox’s are marked under the discussion settings in wp-admin. any tips?

    FYI – if thats matter, the WP “Allow saving my name email” checkbox appears correctly..

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 22 total)
  • Plugin Contributor James Huff

    (@macmanx)

    Volunteer Moderator

    Jetpack doesn’t appear to be connected on your site, at least according to tests from our end.

    Please try disconnecting Jetpack from WordPress.com at Jetpack > Dashboard > Site Connection > Manage Site Connection in your site’s Dashboard, then connect again when prompted.

    Thread Starter roeeyossef

    (@roeeyossef)

    Thanks Jeff,

    Appreciate your response.

    Sure it is. It is activated, connected and the options to subscribe to comments are enabled.

    here’s a screenshot:

    Working & activated

    Plugin Contributor James Huff

    (@macmanx)

    Volunteer Moderator

    I still see it disconnected via tests on our end, so please try disconnecting Jetpack from WordPress.com at Jetpack > Dashboard > Site Connection > Manage Site Connection in your site’s Dashboard, then connect again when prompted.

    Thread Starter roeeyossef

    (@roeeyossef)

    not sure why you cant see i’m connected. anyhow i’ve disconnected and connected again and the issue still exists. (and i’ve tried that before already).

    any ideas?

    Plugin Contributor James Huff

    (@macmanx)

    Volunteer Moderator

    Excellent, it shows as connected now on our end. 🙂

    I can see the right things are active (at least as far as I can tell from our tests).

    Does the option appear if you temporarily switch to the Twenty Seventeen theme?

    Thread Starter roeeyossef

    (@roeeyossef)

    I dont have actually staging for the blog but only local env.

    neither-way i’ve configured jetpack locally to work as staging so it replicates the behaviour of a live site and i’ve change the theme to twenty-serventeen but no success.. i still dont see the checkbox’s.

    • This reply was modified 3 years, 7 months ago by roeeyossef.
    Plugin Contributor James Huff

    (@macmanx)

    Volunteer Moderator

    The checkboxes won’t appear in staging, since subscriptions can only work on a live site.

    The Health Check plugin’s Troubleshooting Mode will allow you to deactivate other plugins and switch to the Twenty Seventeen theme for only your session, meaning no one else will see the changes: https://wordpress.org/plugins/health-check/

    Please give that a try and let us know how it looks.

    Thread Starter roeeyossef

    (@roeeyossef)

    This is a nice plugin,

    I’ve tested the site with it while only Yoast and jetpack are running and the issue remains. No checkbox’s.

    So i wonder wether it has something to do with the Thesis theme i’m using as they mention some conflict with Jetpack (But not with the subscription module).

    so i installed the default Twenty Seventeen theme and troubleshooted the site and still no checkboxes.

    any other idea?

    Thread Starter roeeyossef

    (@roeeyossef)

    on a second thought, i checked for checkbox’s while i was logged in so i dont expect to see those.

    The thing is that i must be logged in in order to troubleshoot with the health check plugin so it’s a bit of a conflict.. :/

    Plugin Contributor James Huff

    (@macmanx)

    Volunteer Moderator

    You don’t need to be logged in to see the boxes. They use the email address you enter into the comment form, so they’re always visible.

    Can you confirm for sure that “Show a ‘follow comments’ option in the comment form” is selected at Jetpack > Settings > Discussion in your site’s Dashboard?

    Thread Starter roeeyossef

    (@roeeyossef)

    i believe you on that 🙂 Yes they are definitely checked…

    Plugin Support supernovia

    (@supernovia)

    Hi @roeeyossef, unfortunately it seems Jetpack is disconnected again. Would you be willing to contact us through Debug in your Jetpack dashboard? There’s a link for Debug at the bottom, and from the results you can contact support.

    Thread Starter roeeyossef

    (@roeeyossef)

    Hi @supernovia,

    Appreciate your time.

    Not sure why you are saying it is disconnected, it is connected as always. Anyhow i disconnected q connected again.

    I’ve just sent your support request as you requested…

    Thread Starter roeeyossef

    (@roeeyossef)

    Hi @supernovia,

    Did you got the chance looking at it?

    Plugin Support supernovia

    (@supernovia)

    Hi, thanks for sending in the support request. And I can see the connection now.

    I still don’t see the comments. I tend to agree with James though that it’s most likely your theme or a plugin taking over the comment section. Your comments do have some extra tabs, for example. Perhaps whatever is adding those is also disabling the follow comments checkbox?

    You mentioned you tried the Troubleshooting Mode in the Health Check plugin and had disabled most plugins, to no avail. Did you also get a chance to switch themes?

Viewing 15 replies - 1 through 15 (of 22 total)
  • The topic ‘subscribe to comments not showing’ is closed to new replies.