WordPress.org

Support

Support » How-To and Troubleshooting » Subpages not working for me

Subpages not working for me

  • Doryman

    @doryman

    Either I am doing something wrong (likely) or WordPress is broken (unlikely as this seems like a very simple and fundamental capability) at this website:

    http://www.skagitbeattheheat.org/

    Please click on “Committees” page. You will see a list of links in there that I inserted manually when I could not get the subpages to appear. If you look at the URLs for the subpages (Transportation, etc.) you will each one has a page_id. Each one one of those subpages was made a child of the parent Committee page, and are seen on the administration pages as children, but he links to the children do not appear when I click on Committee.

    So, have I misunderstood how subpages are supposed to work?

    Thanks,
    Warren

Viewing 2 replies - 1 through 2 (of 2 total)
  • Where are they supposed to appear?
    And yes, even subp-Pages have their own page_id. The hierarchical (parent/child) relationship will be seen in the URL only when you use “nice” permalinks.
    Resource: Using_Permalinks.

    Doryman

    @doryman

    Where are they supposed to appear?

    I was hoping that when I clicked on the “Committees” tab on the home page, a second set of tabs would appear with Transportation, Political Action, etc. and that clicking on any one of those secondary/subordinate tabs would take the user to the desired page.

    Thanks,
    Warren

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Subpages not working for me’ is closed to new replies.
Skip to toolbar