Support » Fixing WordPress » Subpages have stoppped working

Viewing 7 replies - 1 through 7 (of 7 total)
  • Hi, I’ve changed the permalink to avoid confution. But it still doesn’t work. Subpages seem completely broke.
    New permalink is:

    Are you using Custom Menus to create your subpage as I still do not understand where you getting the-younguns-podcast in your url as normally if you use post name as your permalinks then all you should have is

    I don’t know anything about custom menus. I am very new to this. All I thought was that if I selected a parent then it should work absolutely fine. I would have thought the link looks fine and that is usually how a subpage link would look. Surely it makes sense for the URL to be the name of the site followed by the name of the page, followed by the name of the subpage. In fact I can’t even change this when I go to edit permalink. I only have the option to add something to

    Idealy, I would like the subpages to appear as a new menu when you click on the page (like on most websites) but I’ve not discovered how to do that yet.

    I changed one line in my page.hphp file and that was changing a “true” to a “false” for page comments. This made no difference and I ended up having to change it in quickedit for that specific page. Perhaps I have somehow just confused a PHP file, if that is at all possible.
    I’ve changed it back to “true” again by the way but it still doesn’t show the subpage.

    Also, I have now created a new page called ‘test’ and chose the page “David Eagle’s Pick and Mix” as a parent, but that doesn’t show either. So it seems as if parents are just failing completely. It was working fine on Friday, then I log in on Monday and it’s gone wrong, seemingly by itself.


    Instead of creating pages in parent page you need just create page normally like ant other page.

    Then Go to Appearance>>>>Menus create a menu add your pages in menu and drag the pages and arrange them as you wish and for subpage drag slightly to right under parent page.

    Now on left top there should a box with Primary Menu select the menu from dropdown and save

    now you should have a menu with your pages and subpages.

    In settings>>>Permalinks you need to select post name and save .

    Hi, thanks for your reply and for the instructions. I am currently looking into a different way of doing this since I am a blind user and dragging and droppping is not going to work for me. However, I can ask someone sighted to do this until I find a more accessible solution. In Joomla! (which I use at work) you choose a screen position and order by typing in a number or selecting from a list and so I find that to be very accessible. Thanks again for your help.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Subpages have stoppped working’ is closed to new replies.