WordPress.org

Support

Support » How-To and Troubleshooting » SubPage permalinks not working — manually adjusting my .htaccess

SubPage permalinks not working — manually adjusting my .htaccess

  • Currently using 1.5.1.3.

    I have the first 5 lines of the following in my .htaccess and the page comes up fine as

    http://www.mysite.com/mypage/

    I just created a subpage and added the second 5 lines and the subpage doesn’t come up as

    http://www.mysite.com/mypage/mysubpage/

    Have I done something wrong in the RewriteRule? I was just cutting and pasting what seemed logical.

    RewriteRule ^(mypage)/feed/(feed|rdf|rss|rss2|atom)/?$ /index.php?pagename=$1&feed=$2 [QSA,L]
    RewriteRule ^(mypage)/(feed|rdf|rss|rss2|atom)/?$ /index.php?pagename=$1&feed=$2 [QSA,L]
    RewriteRule ^(mypage)/page/?([0-9]{1,})/?$ /index.php?pagename=$1&paged=$2 [QSA,L]
    RewriteRule ^(mypage)/?([0-9]+)?/?$ /index.php?pagename=$1&page=$2 [QSA,L]
    RewriteRule ^(mypage)/trackback/?$ /index.php?pagename=$1&tb=1 [QSA,L]
    RewriteRule ^(mypage/mysubpage)/feed/(feed|rdf|rss|rss2|atom)/?$ /index.php?pagename=$1&feed=$2 [QSA,L]
    RewriteRule ^(mypage/mysubpage)/(feed|rdf|rss|rss2|atom)/?$ /index.php?pagename=$1&feed=$2 [QSA,L]
    RewriteRule ^(mypage/mysubpage)/page/?([0-9]{1,})/?$ /index.php?pagename=$1&paged=$2 [QSA,L]
    RewriteRule ^(mypage/mysubpage)/?([0-9]+)?/?$ /index.php?pagename=$1&page=$2 [QSA,L]
    RewriteRule ^(mypage/mysubpage)/trackback/?$ /index.php?pagename=$1&tb=1 [QSA,L]

  • The topic ‘SubPage permalinks not working — manually adjusting my .htaccess’ is closed to new replies.