WordPress.org

Forums

Transposh WordPress Translation
submitting post in language other than default (6 posts)

  1. jalex206
    Member
    Posted 2 years ago #

    My site default is English, posts are normally in English. Transposh is working great to translate English pages and posts to other languages. But now we have some posts that will be written in non-English language (French and Spanish). I've selected "Enable default language translation" in settings, and I've included custom field "tp_language" set to "fr" for posts written in French. This doesn't seem to work. On the English (default) view of site, the French language version (the original post) shows up.

    We would like the French-written posts to show up in English (translated) and still show in French (as originally written). Is there a way to do this? Much thanks-

    http://wordpress.org/extend/plugins/transposh-translation-filter-for-wordpress/

  2. Ofer Wald
    Member
    Plugin Author

    Posted 2 years ago #

    Well,

    First the tp_language field can be set directly from the metabox that the plugin automatically adds, and what you have requested normally works

    I would appreciate a link to your site to check this further

  3. jalex206
    Member
    Posted 2 years ago #

    We are auto-importing posts from another editor, so hoping to be able to set it in php rather than in wordpress editor metabox (authors won't be using wordpress editor for this site).

    However, to test I tried writing a simple post in French in wordpress editor, then set French as post language using the Transposh meta box. I tried this both before and after publishing a doc, got same result both ways, where the result when looking at post in the site's default language English shows partial translation but there is some strange results and I'm not sure why. This site is just a coding test environment right now but you can view results here:
    post page: https://thinksum.com/2012/10/27/lauto-traduction-2/
    home page (at time of this writing the post is first)
    https://thinksum.com/2012/10/27/lauto-traduction-2/

    Also, I did observe another bug at one point where I had set the language in meta box, was browsing on front-end, and at some point it appeared that the tp_language meta setting got cleared (so when I went back into wordpress editor it had reverted to default).

    Thanks for any help you can provide-

  4. Ofer Wald
    Member
    Plugin Author

    Posted 2 years ago #

    Hi,

    Well, I guess you should be able to set the field in the auto-import process, not that I know exactly how...

    Can you enable anonymous translation on your site?

    Have you enabled translate in default language?

    I don't know why the meta will get cleared, but wordpress + plugins is quite complex, and I can't cover every choice...

    Keep me posted

  5. jalex206
    Member
    Posted 2 years ago #

    Yes- translate in default language is and had been previously enabled.

    I enabled anonymous translation, you can take a look. The top post on the home page (the one that was written in French w/ wordpress editor and marked as French) looks like some of the sentences got translated, some didn't. Also something weird about the title and the <span> wrapping, although maybe that could be corrected w/ the theme.

    If you are able to find anything let me know ... I'm working on some other code on the site, if you can't find anything then I'll see if I can find out more using debugger.

  6. Ofer Wald
    Member
    Plugin Author

    Posted 2 years ago #

    What's the current status of this? Do you still need me to take a look?

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Transposh WordPress Translation
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.