[resolved] submitting comments fail: give error and goes to wp-comments-post.php (3 posts)

  1. sallam
    Posted 4 years ago #


    My blog was fine, then suddenly I discovered that no one can add any comment. Each time I try it, it goes to wp-comments-post.php and shows page not found error.
    I tried reverting to the default theme, but same problem..
    And tried disabling recent plugins, but also no luck..
    I also tried reverting to default permalinks. Same problem exists..

    Any hints please? (I'm using 3.03)

  2. esmi
    Forum Moderator
    Posted 4 years ago #

    Have you tried:

    - deactivating all plugins to see if this resolves the problem? If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - resetting the plugins folder by FTP or phpMyAdmin? Sometimes, an apparently inactive plugin can still cause problems.

    - re-uploading the wp-admin and wp-includes folders from a fresh download of WordPress?

  3. sallam
    Posted 4 years ago #

    I've found out the problem. It was an anti-spam plugin that added a cookie and edited my .htaccess file to add 2 lines of code. I've disabled and removed that plugin about a month ago, but completely forgot about the lines in my htaccess file. Now I did remove those lines and things are fine now.

    Many thanks for your help. I hope this helps those with similar situations.

Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.