Support » Plugin: Google XML Sitemaps » Submitted URL marked ‘noindex’ ERROR!

  • The Google Search Console just sent me notification that I have an error in my sitemap. It says “Submitted URL marked ‘noindex’ “. I cannot fix this issue since the sitemap is not a physical page that I can make changes to. How am I supposed to fix the ‘no-index’ directive on the HTTP headers or meta tag if I can’t manually change/fix the file?? Help!

    • This topic was modified 5 months, 4 weeks ago by  kdavi.

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • I have the same issue with Google Search Console, unfortunately. There is a little box on the plugin settings page where we can list the page IDs of posts/pages that we want to exclude from the sitemap. If you only have a few pages that are noindex, you can get their page Ids and input them into the box, and that will effectively exclude them from the sitemap.

    (However, if you wish to remove the noindex status of the page, this is not done via this plugin. You probably need to edit the page itself in WordPress)

    Our situation is, we have hundreds of noindex nofollow pages. It’s very hard to get the ids of all of them and to input them, comma separated, into the tiny box.

    It would be more logical if the plugin automatically excludes noindex pages from the sitemap, and I am hoping this would be addressed in a future update 🙂

    Sorunun çözümü buradaki linkte var.

    I have the same issue, having received an email from the Google Search Console saying “Submitted URL marked ‘noindex’”. It lists only the sitemap.html file. According to the Console’s robots.txt tester, it is allowed.
    According to the URL inspector: No: ‘noindex’ detected in ‘robots’ meta tag
    I don’t know where that’s coming from.

    In the settings for the plugin, “Add sitemap URL to the virtual robots.txt file.” is checked, there is no physical robots.txt file.

    Thanks.

    The plugin version is 4.1.0, the wordpress is 5.0.3

    • This reply was modified 5 months, 2 weeks ago by  terry777. Reason: to give versions info

    I have the same problem as terry777, an email informing me that “sitemap.html” is marked “noindex”. Is this by design, perhaps, as “sitemap.xml” is NOT listed as being marked “noindex”? Perhaps something somewhere is telling Search Console to only crawl “sitemap.xml” and not “sitemap.html”?

    Plugin version 4.1.0, WordPress 5.1.1

    cpcusteve

    (@cpcusteve)

    Update, found this. Looks like if you uncheck the “Include sitemap in HTML format” box in the plugin settings, the problem goes away. Done it, now awaiting for my site to be re-crawled.Or you can just ignore it!

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.