Support » Plugin: Google XML Sitemaps » Submitted URL marked ‘noindex’

  • ashaduri

    (@ashaduri)



    Hi,

    Today Google informed me that my sitemap URL is marked “noindex”. If I understand the error correctly, Google won’t crawl the sitemap because of this. Indeed, upon inspecting the HTTP headers, I see x-robots-tag: noindex.

    The sitemap is virtually generated by the Google XML Sitemaps plugin.

    How can I remove this header?

    Thanks,
    Alexander

    The page I need help with: [log in to see the link]

Viewing 13 replies - 1 through 13 (of 13 total)
  • steph4nes

    (@steph4nes)

    Hi Ashaduri,
    Sorry but I can’t help… Today I received exactly the same message from Google Search Console Team… And I have the same question than you !
    Hope someone there could tell us how to proceed to solve this ‘noindex’ error…
    Thanks !

    • This reply was modified 2 months ago by  steph4nes.
    followalter

    (@followalter)

    Bump this one. Got the same error mail from Google.

    guirto

    (@guirto)

    Try unchecking this option:

    Include sitemap in HTML format

    It’s on Basic Options.

    rensver

    (@rensver)

    I have the same problem. Unchecking did not remove the noindex

    MJ WebWorx

    (@jansesberger)

    I also have this issue, any new ideas how to solve this?

    Received the same thing from GWT also… “Submitted URL marked ‘noindex’ Your Sitemap does not contain any URLs”

    @guirto
    Does the below help ? i am trying to resolve the same issue every one has.. i am going to try this solution and will reply back if it helped me

    Try unchecking this option:

    Include sitemap in HTML format

    It’s on Basic Options.

    https://www.google.com/webmasters/tools/robots-testing-tool?hl=en&siteUrl=http://pgmumbai.in/

    now it says robots.txt are allowed … awaiting for validation to complete

    let me know if any one could solve the issue

    My sitemap issue appears to have been resolved. Got a message from Google in my GWT account…

    “Index coverage issues successfully fixed for site.”

    Issue: I have been using the ‘Google XML Sitemaps’ plugin for many months prior to my recent sitemap issue. Went to GWT and did a ‘Fetch as Google’ and the Downloaded HTTP response appeared that showed a sitemap issue — no urls appeared.

    Note: Just do a Fetch, not Fetch and Render

    Solution: Deactivated the ‘Google XML Sitemaps’ plugin and replaced it with ‘Google Sitemap by BestWebSoft’. Did another ‘Fetch as Google’ and behold…

    All my website’s urls appeared in the Downloaded HTTP response window. Also, the one sitemap issue that disappeared under Sitemaps in the GWT disappeared as well.

    I am not using the Yoast SEO plugin but a different SEO plugiinstead. I would think that if you can disable the sitemap in Yoast and use the ‘Google Sitemap by BestWebSoft’ plugin instead, your issue will get resolved. In that case, the issue would appear to be with the Yoast sitemap and other sitemap plugins.

    @pgsbluejay, this seem to have work, google still says validating so i am waiting,

    thanks for the reply

    Thanks for the possible solution, but for me this would mean installing and setting up a lot of different sites which would take quite some time. I’d rather await a fix from the original developer.

    comment or delete line:
    if(!headers_sent()) header('X-Robots-Tag: noindex', true, 200);
    in /wp-content/plugins/google-sitemap-generator/sitemap-core.php

Viewing 13 replies - 1 through 13 (of 13 total)
  • You must be logged in to reply to this topic.