Support » Plugin: User Submitted Posts » Submitted Image Doesn't Become Featured Image

  • Resolved lukewarmwater

    (@lukewarmwater)


    Hi,

    I have tried the plug-in and the uploaded images doesn’t seem to be set as the featured image for the post. All the other fields: Post Title, Author, Contents, etc. gets submitted correctly except for the image. The image goes to the media library though but it doesn’t get published as a featured image.

    Thanks in advance for the help!

    http://wordpress.org/plugins/user-submitted-posts/

Viewing 9 replies - 1 through 9 (of 9 total)
  • I have also ensured that the “Set Uploaded Image as Featured Image” checkbox is ticked.

    Plugin Author Jeff Starr

    (@specialk)

    Are you sure the theme supports featured images? You can see how the plugin works using the default WP theme.

    Yep, definitely sure the theme supports featured images. I actually use the featured images on a few pages/custom posts that I have.

    I have several other plug-ins installed as well so I might try and deactivate some of them as it might be possible that one of them has conflicts with your plug-in.

    I only have these plug-ins installed:
    Advanced Custom Fields
    NextGEN Gallery

    Were there any reports of conflicts with the above plug-ins?

    Plugin Author Jeff Starr

    (@specialk)

    Not that I’m aware of.. but there certainly is potential as USP utilizes custom fields for submitted content.

    I tried removing your plug-in and installing it back again and it seems to be working now so I’m not really sure what went wrong. Anyways, it seems to be working but an error message displays now:
    “Notice: Trying to get property of non-object in /home/vol8_5/byethost15.com/b15_13460165/htdocs/wp-content/plugins/user-submitted-posts/user-submitted-posts.php on line 147”

    Plugin Author Jeff Starr

    (@specialk)

    Glad to hear it’s working. The PHP Notice is on the to-do list for the next update. Until then, the plugin should work fine as long as you don’t mind the log spam. In any case, thank you for the feedback.

    I noticed, it appears when I go to a 404 error page. I hope that helps you.

    Thanks for the responses! Lovin’ the plug-in.

    Plugin Author Jeff Starr

    (@specialk)

    Got this fixed in the latest (soon-to-be-released) version of the plugin (20131107).

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Submitted Image Doesn't Become Featured Image’ is closed to new replies.