Support » Plugin: Contact Form 7 » Submit not working for MacOSX Safari/Chrome

  • Resolved cameronchurch


    Hi all

    First off thanks to the developer for releasing this plugin and, more importantly, actively maintaining and growing it!

    It’s very much appreciated and the donation is on the way!

    On that however I can’t seem to get the form to submit in up to date Chrome and Safari browsers on MacOSX.

    Firefox on the same machine works a treat. It also works fine on all browsers on Windows – even IE!!

    The site is and the form is nested in a popup under the Google Analytics tile.

    In terms of resolution steps:
    – Validated the HTML code against the W3C standards
    – included the wp_header and wp_footer inclusion calls
    – tried the browsers on the sample form (which worked)

    My belief is there is something wrong with the placement of the form – perhaps because of its location in a popup?

    Any help would be greatly appreciated.


Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Takayuki Miyoshi


    See FAQ > My contact form behaves oddly on certain browsers.

    Maybe you’ll see some JavaScript errors on Firebug console.

    Hi Takayuki

    Thanks for the quick response.

    I did try that and nothing is thrown in either Chrome Console or Firebug.

    Upon a closer look though the script for v3.3.3 of the CF7 plugin there is a try/catch block around the main function however nothing is done with the caught exception.

    I’ll try changing that to output to the console and see if anything gets thrown.



    So it turns out it has something to do with varnish caching headers. Tracing through the calls of all browsers I’ve found that MACOSX Chrome and Safari were not getting around varnish caching whereas the other browsers were.

    Turning it off has solved my problem – and introduced a new one in how do I get varnish and CF-7 playing together nicely!!!!

    Oh well one for another day.


Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Submit not working for MacOSX Safari/Chrome’ is closed to new replies.