Support » Plugin: WP Advanced Comment » Submit not working (circle turns infinitely)

  • Hi Ravi,

    first of all – great job! You created a very cool plugin! Exactly what I was looking for!

    Unfortunately it’s not working properly on my WordPress site.
    I can display the form to enter a comment, but every time I press the “Submit” button, the circle turns infinitely and nothing happens.

    In the network overview of the developer tools of safari I can see that something happens after I click on this button.
    A XHR request is submitted via Post(http) as resource admin-ajax.php, but nothing happens after that.

    I also tried to disable both jquery options in the plugin settings:
    If I “Disable Plugin’s Jquery”, nothing changes.
    If i “Disable Jquery Validation Plugin” the “submit” button redirects me to the current page and doesn’t commit a comment. Also this option bricks some other plugins using jQuery (like a cookie info plugin or my contact form)

    I really really like your add-on and would like to buy the Pro version in order to use the image upload feature I a am looking for. I would be very glad if you could help me to solve this problem. Thanks in advance!

    (I’m using the Enfold theme for my wordpress)

    https://wordpress.org/plugins/wp-advance-comment/

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Ravi Shakya

    (@ravisakya)

    can u give me a demo url to check the form ?? so i can take a deeper look . can you change the theme to twentysixteen or twentyfifteen and check again ? It might be a theme issue.

    Plugin Author Ravi Shakya

    (@ravisakya)

    The error is coming because it cannot access your wp-admin folder so it cannot use admin-ajax.php.

    You should put this code on your .htaccess

    <Files admin-ajax.php>
    Order allow,deny
    Allow from all
    Satisfy any
    </Files>

    I just remembered that I secured the access to wp-admin folder with a .htpasswd file.

    I have a question, why does your plugin need access to the wp-login.php?

    Now I get the following error message:
    XMLHttpRequest cannot load https://ssl.webpack.de/smokelowandslow.com/wp-login.php. No ‘Access-Control-Allow-Origin’ header is present on the requested resource. Origin ‘….com’ is therefore not allowed access.

    My provider offers me a SSL-Proxy that I’m using for the backend login.
    I guess the prevention of the domain mix is a security feature to protect the user. Do you know a solution for that problem? I guess it should have the same problem without a ssl-proxy. https and http mix should be prevented as well.

    Plugin Author Ravi Shakya

    (@ravisakya)

    I have a question, why does your plugin need access to the wp-login.php?

    The reason for this is it uses ajax to send the data so it needs to access wp-admin/admin-ajax.php file.

    I can see your site is in ‘http’ but another url loads in ‘https’ https://ssl.webpack.de/smokelowandslow.com/wp-login.php. I think that is the problem. I think you should consult with your hosting provider.

    The problem is that some browsers block connections if you want to load some files from a different domain.

    My htaccess had a rewrite rule to forward requests for the wp-login.php to a HTTPS address. I wanted to prevent that it’s possible to establish non-secured connection to the admin login.

    Disabling the rewrite for HTTPS-force in my .htaccess file solved the problem. But I guess it would be more secure for my website to force https.. Unfortunately I still don’t get it why your plugin needs access to the wp-login.php.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Submit not working (circle turns infinitely)’ is closed to new replies.