Support » Plugin: Events Manager » Submit Location – Add Media and content don’t save as formatted

  • This has been going on for a while but I can’t see a consistent cause for it.
    When I start the Submit a Location process, and get to the Details editor window, I use Add Media – select my image from the Media Library; it appears.
    I paste in text from the client’s description, it appears formatted, ie. paragraph and line breaks. All seems OK.

    I submit the location – no faults. But when I view the new location – the image is missing and the text has lost all breaks. It runs together. That 6 lines of description in details is supposed to be 6 separate lines and there is supposed to be a media image above it.

    If I re-edit that information, inserting the missing image again, applying breaks to the text, this second time it seems to save and display correctly.

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • I just with to add that his is happening to all my new submitted locations, not just this one Bonnie View Inn.

    Events Manager v5.9.5

    Submit Location form consists of [location_form]

    CharlieAR

    (@charliear)

    Good morning. I’m not trying to make more work for you. This is intended to give more details as I continue troubleshooting myself.

    I deactivated all my plugins except Elementor Pro and Events Manager. Still having the problem with Locations.
    At the same time I create new Locations I am submitting new Events happening at those Locations. The building and submission of Events seems to be working, Add Media image is present and all text formatted.

    Thanks. Charlie

    Patrick Buntsma

    (@duisterdenhaag)

    Hi Charlie,

    Just to make sure… Because it seems you are just using the interface wrong.

    Creating a location within the Event Page is not the same as creating a new location in the Location Page. It’s a slimmed-down version.

    In the Event Page, everything entered outside of the “Where” meta box belongs to the Event not the location. If you create a new location in the Edit Event Page, only the Location address fields and coordinates will be saved. The Single Location will not have its own content or featured image.

    If you want to set specific info about the location and assign it’s own featured image, you need to do that in the Edit Location Page.

    CharlieAR

    (@charliear)

    OK Patrick. There is just a misunderstanding. I DO use the separate Location editor to create new locations. I prefer to use the EM page “Submit a Location” because that is what I want my clients to eventually use, instead of going into the WP Dashboard for any reason, if I can avoid it.

    That page consists of the shortcode: [location_form]

    Once I have the Location created, I close that page and switch to the EM provided Submit Event. That way, the location name will come up by autocomplete. I never create a location from within a Submit Event.

    Patrick Buntsma

    (@duisterdenhaag)

    Is [location_form] a custom shortcode? Because it doesn’t work on my clean EM install.

    [event_form] does work.

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.