WordPress-to-lead for Salesforce CRM
[resolved] Submit Form using IE (5 posts)

  1. lsdoodle
    Posted 2 years ago #

    When I submit the form in IE 8 and 9, the browser refreshes and if there is an error, it will reload the home page, but ignore my hashtag, so the user never see's the success or if there is an error. Also, when I submit the form it refreshes the page, any way to not do that?


  2. Nick Ciske
    Plugin Author

    Posted 2 years ago #

    Hmmm.. sounds like something else is behind the issue -- the form does save the data and re-display it if there is an error. The reload phenomenon must be being caused by your theme or a plugin.

    Can you try a form on a sub page?
    With Twenty Twelve Activated?
    With all other plugins deactivated?

    Where can I see/test the form having the issue?

  3. Nick Ciske
    Plugin Author

    Posted 2 years ago #

    FYI- I just tested it in IE 8 & 9 and did not encounter the issue you're describing, so it's a not a browser thing (as far as I can tell).

  4. lsdoodle
    Posted 2 years ago #

    Please view what I am experiencing on our site


    The site is a vertical scrolling site, the form is in the #get-started section. If you view this in IE, submit the form with errors, the page will refresh and will not scroll back down to the form to view the errors.

    [Moderator Note: No bumping, thank you.]

  5. Nick Ciske
    Plugin Author

    Posted 2 years ago #

    Ah... that fact that your form is at the bottom of a page and requires an #anchor tag would have been an important thing to mention up front ;-)

    It's not an issue with the plugin -- all it does it submit data to the current URL -- which the browser is responsible for setting. Using PHP_SELF or REQUEST_URI has security implications:

    IE stripping the #hash from that... well that's IE's issue ;-(

    In the end, insuring the form/success message is visible post submit is really a function of your theme -- any workaround I would add to preserve the #anchor in IE may cause other issues or add security issues for all users of the plugin. So, while that may happen if others report the same issue, it's low on the list of things to fix as it requires a workaround and reduces security overall.

    My suggestion in your case would be to use a bit of jQuery to explicitly set the form action to include the needed #hash tag (using the workaround mentioned in the stack exchange article).

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WordPress-to-lead for Salesforce CRM
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic