Support » Fixing WordPress » Submit For Review —- No Publish button

  • OK so I migrated my site onto my host and I can no longer add Uses – Posts – Pages. It comes up with “Submit for Review” instead of “Publish” It doesn’t give me the option to say yes to have it except it.

    So I assumed this had something to do with permissions or an incorrect value in the database. As I read up on it it may have something to do with AUTO_INCREMENT. Anyway so I compared the two views of PhpMyAdmin. One from my staging server where it worked fine and the other from my host server and I found that there is a table row missing.. Row number 14 is missing in my WP-USERMETA database table.

    Does anyone know if this is the problem or am I getting to detailed and there is a more simple fix…

    Please HELP!!! Anyone!!!

Viewing 10 replies - 1 through 10 (of 10 total)
  • esmi

    (@esmi)

    Forum Moderator

    You’re not logged in as an Admin. Using Phpmyadmin (or another MySQL management tool), first backup your database. Then navigate to your wp_usermeta table and locate the meta_key called “wp_capabilities” for your user_id. Change the meta-value for this record to:

    a:1:{s:13:"administrator";b:1;}

    Hi esmi…

    Thank you for getting back to me.

    This is what I have in the current database as “meta_value”
    “a:1:{s:13:”administrator”;s:1:”1″;}” Is this not complete admin?

    On my staging server database the “meta_value” has the same and it allows me to add posts, pages and users. Before I make this change can tell me why it would be different?

    Thanks for your help.

    esmi

    (@esmi)

    Forum Moderator

    No. Please see the value I gave above.

    Hi esmi,
    I Made the change in the database, saved the change, logged back into my site and it still wont allow me to add a post or a page.

    :-/

    esmi

    (@esmi)

    Forum Moderator

    Try:
    – switching to the Twenty Eleven theme by renaming your current theme’s folder inside wp-content/themes and adding “-old” to the end of the folder name using FTP or whatever file management application your host provides.

    resetting the plugins folder by FTP or phpMyAdmin.

    – re-uploading all files & folders – except the wp-content folder – from a fresh download of WordPress.

    could it possibly that I have in my new database a missing row?

    The missing row in the table is

    14 1 wp_dashboard_quick_press_last_post_id 775

    could this have something to do with it?

    esmi

    (@esmi)

    Forum Moderator

    Unlikely – although it does suggest that there might be problems with your database.

    Ok So I just deleted all the wordpress files and folders on my new host root directory except I kept and renamed the wp-content to wp-content_OLD

    I downloaded a current version of WordPress and via FTP I uploaded the new WordPress files and folders, installed this new version I then verified that it worked with activating the Twenty Eleven theme. At this point everything is looking fine. I then tried to ad a new post and page and again it still doesn’t give me a “publish” button. It still has the “Submit for Review” with no way of adding any new page or post.

    I then renamed the old wp-content and activated my new theme and everything is back to normal content wise but still no way to publish a new user – port – or page 🙁

    Any new ideas? Could there be a permissions thing going on with my new host (media temple)? Man I dont know what I try next…

    Again thanks for your help..

    Had this problem recently. I’m aware that there may be numerous causes for it and I’ve certainly seen numerous (successful) solutions.

    Just in case anyone else want’s to try this, my issue was caused by the database user becoming ‘locked out’. To resolve this, I simply logged into my hosting control panel and created a new database user and password.

    I then updated the wp-config.php file to reflect the new DB username and password which then solved the problem.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Submit For Review —- No Publish button’ is closed to new replies.