Support » Plugin: Contact Form by WPForms - Drag & Drop Form Builder for WordPress » Submit button not working on iPhone

  • Resolved activequilibreyv

    (@activequilibreyv)


    Hello,

    I’m having a strange phenomenon on my WP Forms.

    They are working all right on Windows computers and Android phones, but on iPhones, the reCaptcha seems to block the invoice (the rest is working fine).

    I’ve checked my reCaptcha keys twice and tested all three reCaptcha options (v2, invisible v2, and v3).

    I also checked on the html code of the page and reCaptcha mentions seems to be always connected with WPForms. So I guess I don’t have another plugin in conflict with the reCaptcha.

    Any idea on how to solve this ?

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Support Jade

    (@jadeam)

    Hello @activequilibreyv,

    I checked your site and it looks like the issue could be caused by the caching plugin that might be combining and minifying the Javascript files on your site.

    When you have the chance, can you please check your caching plugin settings and disable the optimization on the page where the forms are or you can Exclude WPForms’ assets from minification by going to the Never minify the following JS files to add /wp-content/plugins/wpforms/assets/js/wpforms.js.

    I hope this helps.

    activequilibreyv

    (@activequilibreyv)

    Hi Jade,

    Thanks for digging into this problem. I have applied your tip but unfortunately, it still doesn’t work. Can you check again to see if I missed something and the wpforms.js script is still optimised through some plugin, causing the bug on my forms ?

    If it’s not the case, what could be the cause?

    Thanks
    Yvan

    Plugin Support Jade

    (@jadeam)

    Hello @activequilibreyv,

    When you get the chance, could you please try using the steps in WPBeginner’s detailed guide on troubleshooting WordPress to see if it helps resolve the issue?

    activequilibreyv

    (@activequilibreyv)

    Hi Jade,

    Sorry I should have kept you posted about this. Actually, following your clue about the caching pluggin that might cause my problem, I did dig a bit more thouroughly on my pluggins. I found out that de-activating Async JavaScript did solve the problem. Therefore I wrote to their support and that thread is there: Post on this problem with the Async JS support team

    So my problem is now solved. Thanks for your help!
    Yvan

    Plugin Support Jade

    (@jadeam)

    Hi @activequilibreyv,

    Glad to hear you got it sorted!

    I’m going to go ahead and close this thread for now. But if you have other questions, please feel welcome to continue the conversation.

    Thanks!

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.