Support » Plugin: MC4WP: Mailchimp for WordPress » Submit button not working after update?

  • Resolved SNOR vzw

    (@snorvzw)


    Dear

    We use a simple Mailchimp subscribe form on our website. It has been working for a while, but recently we discovered that it does not work anymore (clicking the button does not do anything). The only thing changed between then and now are updates to WordPress and the plug-in…

    What is wrong? Is it a bug?

    Kind regards,

    Jan Claes
    SNOR vzw

    Where to find the form:
    https://www.snorvzw.be (at the right on big screens)
    – it consists of “first name”, “name”, “email” and “subscribe” (but in Dutch)

    Versions:
    – WordPress 5.3.2
    – MC4WP: Mailchimp for WordPress 4.7.4

    Behavior:
    – Clicking the button does not do anything
    – Empty log even after activating full logging
    – Connection with Mailchimp is okay. I removed a dummy user from our list in Mailchimp, and it shows one less subscriber in the list overview of the Mailchimp settings in the plugin.

    This is the form code copied form the from settings in the plugin:

    Op de hoogte blijven?
    <table>
    <tr>
    <td><label>Voornaam*</label></td>
    <td><input type=”text” name=”FNAME” required=”1″></td>
    </tr>
    <tr>
    <td><label>Familienaam*</label></td>
    <td><input type=”text” name=”LNAME” required=”1″></td>
    </tr>
    <tr>
    <td><label>E-mail* </label></td>
    <td><input type=”email” name=”EMAIL” required=”1″ /></td>
    </tr>
    <tr>
    <td colspan=”2″><input style=”float: right; background: #00afea;” type=”submit” value=”SCHRIJF MIJ IN!” /></td>
    </tr>
    </table>

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 16 total)
  • Plugin Contributor Harish Chouhan

    (@hchouhan)

    Hey @snorvzw,

    Thanks for reaching out to us.

    Are you using any Google ReCaptcha plugin? If yes, please disable them and test again.

    I got an error in the console when testing the form. You can check it at https://www.dropbox.com/s/6uwqds9ulu3a9tt/Screenshot%202019-12-29%2007.08.33.png?dl=0.

    Hi

    Thank you for your quick response! I used both the reCaptcha plugin and the reCaptcha option of the MC4WP plugin.

    I deactivated both and now it worked. I reactivated the reCaptcha plugin and it still worked. I could not reactivate the reCaptcha option in the MC4WP plugin, because it does not show anymore.

    > My problem is now solved, thanks!
    > The MC4WP may have a legacy bug with a reCaptcha option that does not exist anymore (in the free version), but that conflicts with the reCaptcha plugin…

    Best regards,

    Jan Claes
    SNOR vzw

    Plugin Contributor Harish Chouhan

    (@hchouhan)

    Hey Jan,

    Thanks for the update. Yes, we have removed the ReCaptcha option from our plugin and it was only visible if anyone had kept it enabled.

    Hello,

    I have the same issue, but I don’t have the reCaptcha plugin installed. I’ve installed the plugin yesterday. I have set the API key and i get the status ‘CONNECTED’ with green. But for some reason, the form is not submited. This site belongs to my client, and I need to get this solved ASAP.

    Plugin Contributor Lap

    (@lapzor)

    Where can I test the form on your website? Please share a link.

    Hi Lap,

    Thank you for your fast response. You can see the site here:

    https://greenberetfoundation.org/

    The form is visible in the footer of the site, under ‘STAY CONNECTED’.

    Plugin Contributor Lap

    (@lapzor)

    I notice there are 2 subscribe buttons. 1 small white button that is created in our plugin and another larger button that is not part of the form.
    When I test the form by clicking the small white button it works normally.

    However, the text “Thank you for subscribing…” that shows after the button is pressed is green, on a green background (this is controlled by your theme).

    You can fix that with some custom CSS code:

    .mc4wp-response { color: #eccc80; }

    You can add this code trough a plugin like Simple Custom CSS or maybe your theme already offers a way to add extra css via something like Appearance > … > Edit CSS.

    Hope that helps. If you have any questions, please let me know!

    There are two subscription buttons because I tought the subscribe button from the form is needed. I will hide the submit button after I see it work. But I doesn’t work on my end. I mean I tried to send from my computer, from different browesers, I even tried to send it from my phine, with mobile data activated, so it’s not the same IP address. I’ve made the response white, with this line of code:

    .mc4wp-response {
    color: #ffffff;
    }

    The second submit button will trigger the form submit with jquery. But the form is not sent from any button… Can i attach somewhere a printscreen so you can see that when i inspect the page, the network tab from inspector doesn’t get any new request…nor GET or POST… it simply stays the same…no reload, nothing.

    Plugin Contributor Lap

    (@lapzor)

    The free version of the plugin doesn’t use AJAX. Instead the whole page should reload when you submit the form (a normal form post action), and it does for me…

    Submitting the form trough jquery / ajax is out of scope for our free support.

    Hope that helps. If you have any questions, please let me know!

    I’m sorry to insist on this manner, but it shouldn’t show to the user a confirmation text when the subscription works, and maybe when it doesn’t, or if the email is already registered? My form is not showing nothing, if the plugin submits the form normally…how the user is informed, since the page is reloaded, the info text will dissapear… Can you send me a photo or a print-screen to see that response from the submitted form? I’ve tried with different mails and still no response… even the log activity is showing no activity…. And I’ve set it to show everything.

    I tried multiple times, On my front-end site the form does not sumbit, it should redirect to contact page. In the back-end the form submitts and redirects to the contact page…. Can you help me solve this?

    Plugin Contributor Harish Chouhan

    (@hchouhan)

    Hey @bogdan89.

    Please check https://www.dropbox.com/s/hrexwccr5xy5fty/Screenshot%202020-01-10%2019.25.07.png?dl=0.

    Have you customized something in our plugin to place the button outside?

    I would suggest first removing any customizations you have made and test with our default form.

    Hello Harish Chouhan

    I’m sorry about this.I forgot yesterday to post an update so you guys can close this ticket. The issue was not from the second button, that button will send the form, And I need it because it has a cool animation on it, that my client requested. The problem was from another script, that was restricting all the forms to not submit. That was the problem. Thank you for your quick response, but your colegue said that ‘When I test the form by clicking the small white button it works normally.’ It couldn’t work…maybe it was working in the console, making the form to submit with a jquery/javascript function and the id of the form… but on front-end, the form was not submitting.

    In conclusion, the problem wasn’t created by your plugin, and the problem was solved.
    Have a great day!

    • This reply was modified 2 months, 3 weeks ago by bogdan89.
    Plugin Contributor Lap

    (@lapzor)

    When I clicked the small white button the whole page reloaded and I saw the confirmation text. I tested with the email nk6hcqxb3wqk@opayq.com you may see it in your subscriber list.

    Anyway, glad to hear you got it to work for yourself as well. Thanks for letting us know.

    When I updated the MC4WP plugin my submit button disappeared also. The button is actually there but not visible. Is this a known issue with the update?

    website: aprivateaffair.com
    form is at the button and you will see if you hover mouse over right side next to fill inform the mouse activates as if button was there.

    I do not use recaptcha.

    I thought it might be a style issue but any style option I choose it stays the same. I can force a background color to show up but not the word on it. Any thoughts?

    Thanks,
    Rebecca

    • This reply was modified 1 month, 1 week ago by studiobm2019.
Viewing 15 replies - 1 through 15 (of 16 total)
  • You must be logged in to reply to this topic.