Support » Plugin: Contact Form 7 » Submit button not working

  • Resolved stzim

    (@stzim)


    Hello,
    The submit button on Contact Form 5.0.2 does not work on click. Does it maybe have to do with the fact that I have an “Invalid mailbox syntax is used.” error in Additional Headers field? If so, how can I correct it? It is set to Reply-To: <[your-email]>.

    Thanks.

Viewing 15 replies - 1 through 15 (of 15 total)
  • For me the submit button works not on Firefox, but fine on Chrome.
    Nothing found in the console of Firefox.
    No “invalid mailbox syntax” error message.

    Version: 5.0.2

    Thanks,
    Joe

    Hi,

    if you added an acceptance checkbox via acceptance-shortcode you have to check the box, otherwise it seems as if the submit button stops working. (“By default, an acceptance checkbox works as a required field, so you can’t submit the form without selecting the checkbox.” – https://contactform7.com/acceptance-checkbox/) To get some validation messages add acceptance_as_validation: on to the Additional Settings section.

    Yes, I have added acceptance checkbox. I’ve tried it both with checked and unchecked, but upon clicking nothing happens. I also can’t fix Invalid mailbox syntax error in Additional headers field.

    I have the same problem, since the update the submit button isnt work anymore.

    I have no solution for that. In the debugger i see only one warning at line 238 by script.js:
    detail.id = $( data.into ).attr( ‘id’ );

    i’m not a developer. Please, some solution for that…

    I tested deactivating plugins as resolved in https://wordpress.org/support/topic/form-does-not-send-stuck-on-spinning-wheel/#post-10339614

    Won’t work for me. Spinner is still spinning

    Mine isn’t even spinning. It’s like it’s just a button without any action.

    submit button not showing

    Was this ever resolved? Because I have the same issue as stzim: there are no error messages nor are there any animations indicating that the message is being sent. Once you hit, “Send,” nothing happens.

    @megyiu
    The solution for me was to change the form template to:

    <p>Name</p>
    [text* your-name]
    <p>Email</p>
    [email* your-email]
    <p>Subject</p>
    [text* your-subject]
    <p>Message</p>
    [textarea* your-message] …etc.

    <button class=”green-round gr”>Send</button>

    For some reason, with this template the Send button works properly.

    • This reply was modified 1 year, 8 months ago by stzim.

    For me the contact form isn’t working either.
    The strange thing is after I submitted the form through the Enter button, the submit button is working fine!
    Also the button shows the hoover effect wcich in the first place was NOT working either.

    Rafael

    (@rafaelreyeros)

    For me it’s the same as WebExplorer (@webexplorer) writes: FF 63 WIN display unclear Error Message … couldn’t be sent … when using the SEND Button, but hitting ENTER sends uncomplainingly
    Anyone an idea?

    • This reply was modified 1 year, 4 months ago by Rafael.

    Also got the same problem, SEND button not working/nothing happens when pressed.
    Any ideas?

    What do you mean “when you press ENTER it sends your message fine”
    When I press enter, the cursor goes to a new row, how do you send by pressing ENTER?

    jagargal

    (@jagargal)

    Well, i did just what @stzim suggested, it worked pretty good. Strange thing though. Thanks!

    We’re having the same issue. None of the posted solutions work, including creating a new simple form or using the Enter key instead of clicking the button with a mouse.

    This problem came up after migrating to a new server with PHP 7.3 (php-fpm) and NGINX (instead of Apache). Not sure if those are factors or if there is a permission issue. I can’t find any errors in the logs or in the console.

    I disabled the ajax load by changing

    if ( ! defined( 'WPCF7_LOAD_JS' ) ) {
    	define( 'WPCF7_LOAD_JS', true );
    }

    to

    if ( ! defined( 'WPCF7_LOAD_JS' ) ) {
    	define( 'WPCF7_LOAD_JS', false );
    }

    as a temporary fix. The forms work, but we would prefer to be able to utilize ajax submission.

    • This reply was modified 9 months, 1 week ago by Mark.
Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Submit button not working’ is closed to new replies.