Support » Plugin: Contact Form 7 » Submit Button Not Working

  • I have a form on this page http://islyophilization.org/2017-east-coast-registration/ and when I hit submit, nothing happens. It’s weird because it literally just stopped working one day. Here’s what I’ve done so far, I tried a different theme, tried deactivating all plugins, and I’ve tried changing a few settings in the form configuration but the button still wont send. It doesn’t make any sense. Any help would be greatly appreciated.

    Thank You.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Takayuki Miyoshi

    (@takayukister)

    What do you have in the Form tab?

    Same thing happened to us with a site just today. About a month ago we had this problem when updating from 4.7.4 to 4.8, to coincide with the new version of WordPress released.

    We noticed many reporting 4.8 is broken, so we manually rolled back to 4.7.4 and this fixed everything.

    Then a week ago we updated again to 4.8 and the form seemed to be working fine again.
    But suddenly today it is no longer working.

    As a temporary fix we have rolled back to 4.7.4 and this has corrected the issue.
    @gratschultz2013 I recommend if you’re stuck and really need that form working, give it a try rolling back manually to 4.7.4 and see if that fixes it for you.

    FYI: You can find it by going here: https://wordpress.org/plugins/contact-form-7/advanced/ and then scroll to the bottom and choose “4.7” and hit Download. That’ll give you 4.7.4 and you can rename your existing “contact-form-7” folder in your “plugins” directory (just add a 1 to it or something). Then extract the ZIP of 4.7.4 and FTP to your plugins directory just the “contact-form-7” folder. Go to your Plugins area within WordPress and hit refresh and you should see your Contact Form 7 listing go back to 4.7.4 and show that a newer version is available (ie. 4.8). Then test your form and see if that works. If it’s worse, or some other error occurs, you can always delete the “contact-form-7” folder you just uploaded and rename your original one back from (eg.) “1contact-form-7” to “contact-form-7 and you’ll have version 4.8 back in place exactly as it was before you attempted this manual rollback.

    I hope that helps.

    Meanwhile, we’re really waiting here for a Contact Form 7 version that works correctly. Unfortunately, something has gone wrong with 4.8 a month ago and it doesn’t appear to be fixed yet.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Submit Button Not Working’ is closed to new replies.