Support » Plugins and Hacks » Genesis eNews Extended » [Resolved] Submit Button Not Displaying

[Resolved] Submit Button Not Displaying

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Brandon Kraft


    Hey Brad,

    It’s totally a feature of Epik, if you will. Check out the CSS (I’m looking at the theme demo’s since I don’t own it).

    Starting at line 2141, that set of rules is to hide the submit button. Can you let them know that their issue is with their CSS too?


    Ok thanks Brandon.

    Sorry to open an old wound, but I have the same issue on my site, here:

    I’m just using the very standard “genesis” theme, and my custom style.css isn’t set to do anything to button styles.

    Any ideas?



    Plugin Author Brandon Kraft


    Hi Peter,

    You’ll want to use a child theme with Genesis. If you want the same layout as this one, you can download the Genesis Sample theme from http://my.studiopress.com

    With the default theme now, the submit button is hidden, expecting the user to press Enter on their keyboards.

    Once you have a child theme up, you’ll want to look for the CSS in the child theme’s style.css that says:

    .enews input[type="submit"], .search-form input[type="submit"] {
    border: 0;
    clip: rect(0, 0, 0, 0);
    height: 1px;
    margin: -1px;
    overflow: hidden;
    padding: 0;
    position: absolute;
    width: 1px;

    To add the submit button to the enews widget, remove the first part of the first line .enews input[type=submit"],. If you would like to add the submit button to both the enews widget and the search field, remove all of that code.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘[Resolved] Submit Button Not Displaying’ is closed to new replies.