Support » Themes and Templates » [Resolved] Submit & $_POST Issues in Admin Tab

[Resolved] Submit & $_POST Issues in Admin Tab

  • My theme uses two Presentation tabs (this was an executive decision I felt was needed to reduce the amount of page people had to scroll through) and I’m having issues with submitted information displaying after the “Update Options” button is pressed. I’m fairly new to PHP, so I’m having difficulty with figuring ou where the problem lies, but I have a feeling it has to do with the way the form is setup. Particularly in this bit here:

    <form enctype="multipart/form-data" name="dofollow" action="" method="post">
    <input type="hidden" name="action" value="<?php stylesupdate(); ?>" />
    <input type="hidden" name="page_options" value="'dofollow_timeout'" />

    To be more specific, my theme gives the options to edit the CSS information from the admin panel, through use of storing the color data in the header file. In the theme’s control panel, I’ve coded a display like this:


    The problem is that even when I put in a new color code, the color isn’t updating initially. If I refresh the page a second time, without pressing the submit button, the newly modified color appears fine. I’ve double-checked the actual code that saves the colors to an array and pulls them out again and I can’t see that I’ve done anything wrong there. I do know that it *is* saving the information the first time the Submit button is press though. Other than that, I’m at a loss.

    Any help or point in the right direction would be appreciated. Thanks.

Viewing 1 replies (of 1 total)
  • I noticed you marked this [Resolved], but, can you let everyone else know what you did to “Resolve” it? This might help others that are having the same problem as you had.. =) 😉


Viewing 1 replies (of 1 total)
  • The topic ‘[Resolved] Submit & $_POST Issues in Admin Tab’ is closed to new replies.