WordPress.org

Support

Support » Themes and Templates » [Resolved] submenus not showing

[Resolved] submenus not showing

  • Hi,
    I’ve installed the Frontier theme. The example image shows sub menus, and when I go into the menus page it shows the pages I’ve chosen as child pages correctly, however when I view my site they are all showing on the menu, with no sub menus. I can’t figure out where I’m going wrong, could anyone advise please?
    Thanks

Viewing 4 replies - 1 through 4 (of 4 total)
  • Theme Author ronangelo
    Participant

    @ronangelo

    Please post a link to your site.

    Did you correctly assign the menu as Primary and not Top Bar? And the sub-menu items are properly set ( indented ) similar to this image? http://codex.wordpress.org/File:wp3.8menu-screen6.png

    Thankyou!!!

    I had it set as Top Bar. If you don’t mind, could you explain why it shouldn’t be this.

    That’s been really annoying me for so long – thank you so much.

    Theme Author ronangelo
    Participant

    @ronangelo

    Top Bar menu is the one shown on the black bar as opposed to the Primary Menu which is displayed under the header. The top bar menu is meant for short a menu list(as seen on my blog) and does not accept sub-menus. If you’ve set a top bar menu on the menu page, you’ll also need to enable it on Frontier Options -> Display

    Aah, thanks for explaining that – it seems so obvious now.
    I can’t see a Display option under Frontier Options though – sorry!

    Thanks

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘[Resolved] submenus not showing’ is closed to new replies.