Support » Theme: Spacious » Submenu wrongly positioned for narrow view

  • Resolved ricflams

    (@ricflams)


    Just started using Spacious. Lovely theme!

    However, I noticed that on narrow views (eg my iPad) the rightmost menu-item’s submenu would appear in the wrong position, almost under the second-rightmost menu-item. The submenu also wrongly stay up instead of disappearing.

    Here are two screenshots of the effect:
    https://photos.app.goo.gl/VjM8HMuPt3tsLDnP9
    https://photos.app.goo.gl/8SUnp3ryu9KbZghy5

    I hovered over rightmost menu-item “Ejerforeningen” but the submenu appear beneath “Dagligdag”. When Ejerforeningen lose focus the submenu stay up, even when hovering over another menu-item, here “Dit hjem”.

    Specifically, it happens when the spacious-menu--left style is applied, at https://themes.trac.wordpress.org/browser/spacious/1.7.3/js/navigation.js?rev=131635#L130
    I tried just doing return false instead and when the style isn’t applied the menu works fine regardless of how narrow the view is.

    thanks for your time,
    Richard

    • This topic was modified 1 week, 5 days ago by ricflams. Reason: Made a typo

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • @ricflams

    Actually, there was theme update regarding the menu display out of viewport, ie, if the parent menu have too many sub-menus, ie, childrens then, if it goes out of viewport then, it was displayed at left side as you’ve shown in the screenshot. Hope this clarifies your concern.

    Thanks.

    Thanks for the reply.

    I’m afraid too many sub-menus is not the problem here.
    I added a testmenu consisting of just two menu-items “Menu1” and “Menu2” (both custom links to #), each just with one item in their sub-menus. The problem still occurs.

    See screenshot here:
    https://photos.app.goo.gl/vJ6BapJw58v3CYoM9

    I first hovered over Menu2 and because of the narrow view its submenu is shown at the wrong position. I then hover over Menu1 and its submenu is shown correctly, but Menu2’s submenu stay up.

    thanks, Richard

    Update: FYI, I disabled the “spacious-menu–left”-style in the theme as a crude work-around for the problem, so the site no longer has this issue.

    @ricflams,

    Glad you fixed the issue yourself. 🙂 If it is still an issue we will have a team discussion and fixed as soon as possible.

    ricflams

    (@ricflams)

    Hi @asheshmagar

    Thanks for the response.

    To make it completely clear: it is very much still an issue in the theme.

    I “fixed” it by modifying the navigation at https://themes.trac.wordpress.org/browser/spacious/1.7.3/js/navigation.js?rev=131635#L130 to simply say “return false” instead of applying the style.

    That’s not really a sustainable fix, so I surely think you would like to look into it. It’s not a rare edge case but can be easily reproduced by the simplest of menus, as shown in the screenshot in my previous post with Menu1 and Menu2.

    Thanks, Richard

    @ricflams

    Ok. We will have a look on it once again and if found the same issue then, we will probably fix that up within theme update. So, thank you for your patience and understanding.

    Thanks.

    Thanks a lot, @nitushrestha10

    I will mark this topic as resolved, then 👍
    (I guess that’s the prudent thing to do, now that you’re taking action on it)

    Richard

    • This reply was modified 6 days, 2 hours ago by ricflams. Reason: silly typo
Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.