Support » Themes and Templates » Submenu Items Don't Appear Even Though They Are in the Source

Submenu Items Don't Appear Even Though They Are in the Source

  • On this site I created a child page (Books) and added that page as a child item to the parent page’s menu item (CR Bookstore) in the custom menu. I saved the menu and the selection of that menu for use (on the left).

    When I hover over the parent item’s menu entry, the child does not show up as an option. Strangely, it is listed in the page code:

    <div id="nav"><div class="menu-main-container"><ul id="menu-main" class="menu"><li id="menu-item-32" class="menu-item menu-item-type-custom menu-item-object-custom current-menu-item current_page_item menu-item-home menu-item-32"><a href="http://www.cr-ministries.org/">Home</a></li>
    <li id="menu-item-81" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-81"><a href="http://www.cr-ministries.org/cr-bookstore/">CR Bookstore</a>
    <ul class="sub-menu">
    	<li id="menu-item-107" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-107"><a href="http://www.cr-ministries.org/cr-bookstore/books/">Books</a></li>
    <li id="menu-item-36" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-36"><a href="http://www.cr-ministries.org/contact/">Contact Us</a></li>

    Based on the code I would think the child page item would be showing all the time, but it isn’t.

  • The topic ‘Submenu Items Don't Appear Even Though They Are in the Source’ is closed to new replies.