Support » Plugins and Hacks » [Resolved] Submenu disappears after updating to Genesis 1.9 and 1.9.1

[Resolved] Submenu disappears after updating to Genesis 1.9 and 1.9.1

Viewing 10 replies - 1 through 10 (of 10 total)
  • Brandon Kraft


    Happiness Engineer

    Are there menus chosen in Appearance->Menus for the primary and secondary nav?

    Brandon Kraft


    Happiness Engineer

    Also, checking out the actual StudioPress forum is best: http://www.studiopress.com/forums/ as the forums for Genesis.

    If you purchased Genesis, you can submit a help ticket at http://my.studiopress.com

    I made the Genesis update 1.9.1 and now the header text shows up over my header image. I went to the header section under appearances and there is a box that says “show header text”. I uncheck the box and only the image shows up in the preview, which is what I want. However, when I hit save, it goes back to having this header text floating over the image. Under general settings, I deleted the site title and tagline. Now it looks fine, but I think this may be bad for SEO. This works for now, but I’m wondering if Genesis will fix this. Does anyone have any advice?

    Brandon Kraft


    Happiness Engineer

    Will– likely it is likely something minor.

    I’d suggest posting a new thread at http://www.studiopress.com/forums/ and including the address of your site.

    There doesn’t seem to be a checkbox for primary and secondary nav in version 1.9. Or, they moved it to a special place. When I restored it to 1.8.2 the selection boxes returned and everything worked again.

    I’ll post to Genesis forum, too. Thanks.

    Also, I did select a menu for the primary nav and did NOT select a menu for the secondary nav under Appearance –> Menus.

    Plugin Author Bill Erickson


    Thanks for pointing this out. With 1.9 Genesis did change the way the menus worked.

    In 1.8, you went to Genesis > Theme Settings, checked a location to use, then went to Appearance > Menus and assigned a menu for that location.

    In 1.9, this was simplified to just the Appearance > Menus part (no need for a checkbox, just see if they’ve assigned a menu to that location).

    While I think this was a useful simplification, it did break the way this plugin worked (check the box in Genesis > Theme Settings, but don’t assign a menu).

    I’ve modified the plugin to now work with Genesis 1.9. All you need to do is activate the plugin, and as long as a secondary menu location is registered, it will work.

    Try using the new version of the plugin (1.5) and let me know if this works for you.

    Thanks. Plugin version 1.5 works with Genesis 1.9.1.


    I am running a couple of WordPress 2.5.1 networks with Genesis 1.9.1

    On a site with pre-existing secondary menus and the default Genesis theme, when I activate v1.5 of this plugin, the secondary menu navigation menu theme location is depopulated.

    Unfortunately deactivating all plugins except this one does not correct the problem 🙁

    (We are using the Networks+ MU plugin)

    Sorry for being a wally!

    Even though the secondary menu theme location empty, the subpages are still displayed 🙂

    Unfortunately the child pages aren’t using fancy drop-downs for grandchild pages, I guess this is just a matter of styling?

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘[Resolved] Submenu disappears after updating to Genesis 1.9 and 1.9.1’ is closed to new replies.