Support » Networking WordPress » Subdomains and URLs???

  • Resolved kokaku

    (@kokaku)


    I have setup multisite using subdomains thinking that it would allow me to have multiple sites hosted by the same WP install where each site has its own domain name.

    What I want… A.com and S.com
    What I see… A.com and S.com 301 redirects to S.A.com

    If I setup S.com as a primary mapping on S.A.com, I get a ‘too many redirects error’. On my host, A.com and S.com both have an A record pointing to the IP address of A.com (where all the sites live). I could setup CNAME records if that will help, but none of the documention I found was clear on how that works – what do I map to what?

    Is there a way to setup S.com to use the multisite install but retain the S.com URL? If not, is the only solution to have multiple installs with multiple databases?

    thank you

Viewing 6 replies - 1 through 6 (of 6 total)
  • Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    Lead Plugin Wrangler

    I already have the domain mapping plugin installed. In it, I have S.com and S.A.com as a primary mapping (that’s what I meant in the 3rd paragraph about the ‘too many redirects error’ and setting up S.com as a primary mapping). It didn’t appear to let me map A.com at all since that’s the core domain of the network.

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    Lead Plugin Wrangler

    DON’T map domainA.com 🙂

    Have you read http://ottopress.com/2010/wordpress-3-0-multisite-domain-mapping-tutorial/ and followed those steps?

    I have read that, though not all of its steps mapped to my conditions. For one, it took me a while to realize the ID comes from the db since it doesn’t show up in the sites list. Also, I have a subdomain setup, not a subdirectory setup.

    What I see in my Network Admin > Sites list is this…
    Domain A.com with Mapping [none]
    Domain S with Mapping S.com (the Domain is S, not S.com, since it is a subdomain setup?)

    In S’s Dashboard > Tools > Mapping…
    S.com
    S.A.com as Primary

    As I said in my original post, when I tried to set S.com to be the Primary, I got a ‘too many redirects’ error.

    One other consideration that I haven’t explored – the site is setup on Nginx with a server with ‘server_name S.com A.com *.A.com’ – do I need to tweak my config files to make this work?

    How bizarre – after some more searching and reading, I tried making S.com primary again and maybe the DNS changes needed time to propagate?, because now it works.

    I also made a change to DNS settings on my host to remove the A record for S.com and replace it with a CNAME record mapping * to A.com

    Not sure which is responsible but now it works.

    Thank you for your help along the way (an added voice can help keep one going).

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    Lead Plugin Wrangler

    maybe the DNS changes needed time to propagate

    They always do 🙂 Took me 4 hours last night cause I’m a dumbass and forgot to lower my TTL before changing an IP.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Subdomains and URLs???’ is closed to new replies.