Support » Networking WordPress » subdomain multisite – permalinks not working anymore

  • Hi everyone,

    I hope I’m not repeating anything, but I’ve been looking around for a solution all weekend and couldnt find one.
    I have installed the multisite on my wordpress. Right now there is only one site on there, but I want to build another site very soon. Subdomain was my choice and wordpress didnt let me choose anything else, which was fine.
    I read that choosing subdomain would not cuase any permalink problems, as it happens with subdirectory.
    When it didnt work at first I saw somewhere that I only need to go into the sites Settings – Permalinks and click on submit again. That seemed to have fixed it.
    But then I created a new blog post and published it and everything crashed again.
    I normally use postname as permalink setting and I want to keep using it if possible. But right now the only setting that works is default, so i have the id shown instead of postname or date.
    I tried changing the permalink structure in network settings – site edit – settings, but did not help at all.
    Also, when i installed multisite it updated everything to WP 3.4.1, not sure if that makes a difference.
    Whenever i look for people who had the same issue they chose subdirectory/subfolders.
    Just one more thing, when I installed multisite with subdomains it mentioned somewhere that i have to configure wildcard subdomains. I wasnt quite sure what that is, does it have anything to do with my issue? if so, what do i have to do?

    can anyone help, i would really appreciate it.

Viewing 10 replies - 1 through 10 (of 10 total)
  • Wildcard subdomains only matters when you start making subsites.

    What’s in your .htaccess?

    Hi Mika,

    thanks for your quick reply. Looking for solutions I should have known thtat you need my htaccess text. Here it is:

    <Directory "/Library/WebServer/Documents">
    	RewriteEngine On
    	RewriteBase /
    	RewriteRule ^index\.php$ - [L]
    	# uploaded files
    	RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]
    	# add a trailing slash to /wp-admin
    	RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    	RewriteCond %{REQUEST_FILENAME} -f [OR]
    	RewriteCond %{REQUEST_FILENAME} -d
    	RewriteRule ^ - [L]
    	RewriteRule  ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    	RewriteRule  ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    	RewriteRule . index.php [L]

    That… Hm. Why is it wrapped in <Directory "/Library/WebServer/Documents"> ?

    mh…not too sure to be honest. I think i didnt have it after installing multisite but at some point it ended up like it. You think I should take the “<Directory …>” bits off and see? Ill try and let you know.

    ok, i took the first and last directory bit out, but its still not working when I try to choose postname.
    I also had a look at the permalink structure setting in my network admin settings but the field is empty. is that ok? i did try it with /%postname%/ but it didnt make anything better.

    Hi Mika,
    do you have any other idea?
    its been really bugging me but I cannot find the problem. But all partners and links that are linking to posts and pages on my site have contacted me now saying that their links dont work.
    is there really no way of getting postname to work?
    Thank you!

    Sorry, I’m off on Vacation so I don’t check in as often (sunshine, yay!)

    Is that the entire .htccess file?

    And are you sure it’s named .htaccess?

    The next step I’d have is ask my webhost if there’s something obvious I’m missing.

    oh i’m sorry, didnt know. At least some of us are getting sunshine 🙂
    yes, thats all. and it has the right name and its in the right folder. Im with 123-reg, unfortunately. would never recommend them, they are a pain. but I’ll check with them. thanks for the tip.

    You’re not on Windows hosting, are you?

    I’m having the same problem. Installed subdomain multisite, them installed child theme everything work fine. I use a /%postname%/ in permalinks on the main site and use it on the subdomained one as wel. And when I click on enything exept logo or home (on the subdomain site)it redirect me to main page of the main site.

    my htaccess is:

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]

    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ – [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘subdomain multisite – permalinks not working anymore’ is closed to new replies.