WordPress.org

Forums

Subdomain creation failed - Centos6/plesk11.5 (9 posts)

  1. aniclip
    Member
    Posted 1 year ago #

    SERVER : centOs with Plesk 11.5 - domain use wildcard via a dns config
    (MYDOMAIN.com replace the real domain)

    1. I install wordpress and theme with multisite option.

    2. I config it to use subdomain

    3. its ok with wordpress but no subdomain created on the server.

    1. I create /var/www/vhosts/MYDOMAIN.com/conf/vhost.conf
    with these lines inside :

    *. MYDOMAIN.com
    <Directory /var/www/vhosts/MYDOMAIN.com/>
    AllowOverride FileInfo Options
    php_admin_flag safe_mode off
    </Directory>

    2. I create a line in DNS settings : A with the IP number

    3. I restart apache

    4. I relauch configuration : /usr/local/psa/admin/sbin/httpdmng --reconfigure-all

    5. I restart apache

    DNS

    I wait 10 hours to be sure of dns A settings

    I TRY TO CREATE SUBDOMAIN

    1. account successfully created

    2. account activated :

    3. I login via MYDOMAIN.com (no sub domain) and it say :
    As a new WordPress user, you should go to your dashboard to delete this page and create new pages for your content. Have fun!

    If I press, it give this address why ??
    http://localhost/wordpress-3.8.2/wordpress/wp-admin/

    Thank you

  2. It sounds like you don't even have your site running properly.

    Did you install WP locally and then transfer it to domain.com?

  3. aniclip
    Member
    Posted 1 year ago #

    No direct install on the server, and modify wp-config and .htaccess as mention when creating network :

    //WP-config add-on

    define('MULTISITE', true);
    define('SUBDOMAIN_INSTALL', true);
    define('DOMAIN_CURRENT_SITE', 'www.mydomain.fr');
    define('PATH_CURRENT_SITE', '/');
    define('SITE_ID_CURRENT_SITE', 1);
    define('BLOG_ID_CURRENT_SITE', 1);

    //HTACCESS

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^wp-admin$ wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^(wp-(content|admin|includes).*) $1 [L]
    RewriteRule ^(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]

    Have you got an idea ? thank you

  4. Was WP working BEFORE you activated Multisite?

  5. aniclip
    Member
    Posted 1 year ago #

    Yes it was working, do you whats the problem ?

  6. I don't know, which is why we're debugging with you :) This is how it works.

    When you set up plesk, did you set up wildcard subdomains? Please keep in mind, I'm not suggesting you SHOULD do that, I'm asking what you DID. I'm not you, so I have to ask small questions to understand where you are and how you got there. I could ask the bigger ones, but they get confusing. Start small :)

  7. aniclip
    Member
    Posted 1 year ago #

    Yes I understand and I thank you.
    I config DNS via plesk and apply wildcard. A DNS *.mydomain.com related to the IP

    Thank you for your help

  8. I know on CentOS that's only half of it. You have to also add a new subdomain of * (yes, the asterisk). Did you do that?

  9. aniclip
    Member
    Posted 1 year ago #

    create a subdomain with a * ?
    No I didnt do it , Im gonna try to see

Topic Closed

This topic has been closed to new replies.

About this Topic