Subdirectory Woes (11 posts)

  1. withoutink
    Posted 6 years ago #

    I have a problem I cant seem to resolve. It's beginning to drive me bonkers.

    I have WP installed in my root dir of my domain. Inside the root there are also some sub directories that have nothing at all to do with WP. Basically some third party apps that should run when you enter the full url.

    Example: mydomain.com/3rdpartyapp

    WP thinks this is a permalink that doesn't exist and it automatically throws a 404. I need it to stop doing that ;)

    I killed my htaccess file and regenerated my permalinks, cleared my browser cache and still - no love.

    Any suggestions?

  2. withoutink
    Posted 6 years ago #


  3. Clayton James
    Posted 6 years ago #

    Just some thoughts. Is it a php/databse driven app that could be improperly configured (setup issue)? If not, does the directory contain an index file? If it does, can you force it to load by typing mydomain.com/3rdpartyapp/index.(ext) in the browser? What happens if you just add a trailing slash? Is 404 the only error you are getting, and what app are you trying to run from the sub-directory? That might reveal a clue or two.

  4. distefam
    Posted 6 years ago #

    I am having this same issue both with an install of mint and fever. I recently migrated my site to a new web host and the site itself is working fine, however, when I attempt to navigate to one of the third party applications via http://mydomain.com/app I am unable to get the application to load. Actually, in one instance (mint) the page loads but does not apply any formatting, in the other instance (fever) I get a 404.

    I attempted your suggestions, for fever I navigated to http://mydomain.com/fever/boot.php but to no avail.

    Just to let you know I have my wordpress install in a wordpress folder in my root directory. This is the same directory in which my mint and fever folders reside. I have copied the exact same structure and databases from my previous server. I have also copied the same .htaccess file into my server's root directory.

    Thank you in advance for any help.

  5. onthenetdollars
    Posted 6 years ago #

    I am also having this same issue.

    Going direct to the index.php is not working for me.

    Anyone else have any ideas?

  6. withoutink
    Posted 6 years ago #

    Just figured I would update you. Still no success, it doesn't really matter what added script I use. It still doesn't work (ive tried a few).

  7. epsil
    Posted 5 years ago #

    I have the same problem as you all do.
    If I remove the .htaccess file from the subdirectory of the 3rd party app (in my case oscommerce), i can go there. With the .htaccess file intact WordPress injects itself and redirects me to its 404 page.

    I tried this folder redirect but without avail.

    RewriteCond %{REQUEST_URI} !^/(yourfolder|yourfolder/.*)$

    WordPress still redirects to its 404.

    Any help will be very welcomed.

  8. epsil
    Posted 5 years ago #

    Well, at last I found a solution that worked fine for me.
    Try it and let me know if it works for you too.

    Add this line of code inside the .htaccess of any sub-directory that you don't want to be taken into account by WordPress:

    ErrorDocument 401 "Unauthorized"

    Remember, don't add this code into the WordPress .htaccess file, but inside other sub-directories. In my case, it was an oscommerce install.

    Hope it helps!

  9. mashby
    Posted 5 years ago #

    I'm running into the same issue and nothing seems to work.

    According to the Fever web site

    Your CMS or blogging software might be interfering with the request. Try adding an .htaccess file to the /fever/ directory containing the following:

    <IfModule mod_rewrite.c>
        RewriteEngine   off

    And I tried epsil's suggestion of ErrorDocument 401 "Unauthorized" and that didn't work either.

    Anyone have any other suggestions?

  10. Daniel Watrous
    Posted 5 years ago #

    I'm having this same problem. Has anyone found a solution?

  11. Daniel Watrous
    Posted 5 years ago #

    I was able to resolve this by setting permissions on the files in the subdirectory and tweaking a setting in my third party app.

Topic Closed

This topic has been closed to new replies.

About this Topic