Support » Networking WordPress » Subdirectory Problems

  • Resolved darcmosch

    (@darcmosch)


    I am having trouble setting up my network. Every site I cannot get to the front or backend of any of my subdirectory sites. All the themes uploaded correctly and everytime I navigate I get a 404 Error and Object Not Found. I am sure the answer is on here somewhere but I cannot find what is my problem. I hope to hear from someone soon. Thanks

Viewing 15 replies - 16 through 30 (of 47 total)
  • Use Code Tags, please 🙂 Swear to pogo sticks, it helps us 😉

    Change AllowOverride None to AllowOverride All for grins and giggles.

    Ok, got it. I’m new here glad you let me know the proper way 🙂 but that is the only line I need to change?

    Possibly. Won’t know till you try! (Sometimes servers need other changes, sometimes they don’t. Every server is a snowflake.)

    a snowflake huh? That reference never comes with good stories D=

    Heh. I mean each server is different (like a snowflake). No two are 100% alike. Statistical impossibility. Thus I like to remind people that the reason there isn’t always one perfect answer is because of that individuality.

    All of my AllowOverride’s are set to Allow.

    And?

    Lol sorry and i am only seeing the HTML

    *Edit*
    What all do you need from me to fix this problem? I know it has something to do with httpd.conf or .htaccess

    Check your .htaccess against http://codex.wordpress.org/Create_A_Network#.htaccess_and_Mod_Rewrite

    As for httpd.conf, I’m looking for my notes. I need to keep them more handy, but I think you may need to kick the options some.

    Here is what it says. The last couple of lines look different, but they are what my WP install says I need for it.

    RewriteEngine On
    RewriteBase /blog/
    RewriteRule ^index\.php$ - [L]
    
    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule  ^[_0-9a-zA-Z-]+/(wp-(content|admin|includes).*) $1 [L]
    RewriteRule  ^[_0-9a-zA-Z-]+/(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]

    By ‘compare’ I meant you could do that on your own 😉

    .htaccess is fine.

    Would it make more sense if I told you that I barely know what I am doing right now? I don’t know server language all that well, which is why it seems that I am asking a ton of stupid questions, but we all got to start somewhere right? I guess the only other culprit would be my httpd.conf file?

    Here is my httpd.conf, whatever good that’ll do

    <script src=”http://pastebin.com/embed_js.php?i=sr1W6g1X”></script>

    Heh. No shame in being new. I did guess that 😉

    I’m pretty sure it’s the httpd.conf, but I’m not as well versed in that as I should be, so I’m rooting around trying to remember what Andrea said. I think you have to add Options Indexes FollowSymLinks below the AllowOverride line.

    Ok, gotch. I know I didn’t do that right but I’m a little spent (and lazy) to go back and fix the link in my previous post, but that is my entire httpd.conf file. The thing that confused me the most is which AllowOverride is WP talking about? I found 3 when I search within the file

Viewing 15 replies - 16 through 30 (of 47 total)
  • The topic ‘Subdirectory Problems’ is closed to new replies.